Event ID 4096 - "Java -1" error in event log and error "Failed to connect to server" at Login on a Windows 2003 SP2

book

Article ID: 178164

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

Event ID 4096 - "Java -1" error in event log and the error "Failed to connect to server" at Login, with HTTP 503 in scm-server-0.log on a Windows 2003 SP2

Symptoms
Symantec Endpoint Protection Manager was working fine and after a system reboot problem occurs.
  • Symantec Endpoint Protection Manager service does not stay started and generates Event ID 4096 in Event Viewer.
  • scm-server-0.log shows http return code 503.
  • Upon browsing 'Default Web Site' and 'Symantec Web Server' it says "Service Unavailable".
  • Default AppPool will not stay active.


Cause

1. Microsoft Windows Update KB973917 has crashed the IIS 6.0 2. Previous to the installation of the Windows Update KB973917 update, one or more of the core IIS .dll files were not at the correct file version. Specifically, the earlier installation of Windows Server 2003 Service Pack 2 on the server did not complete successfully, leaving some of the IIS .dlls at the Service Pack 1 level while bringing others up to the Service Pack 2 level. The IIS services had been able to run successfully even with that file mismatch in place. However, the installation of the KB973917 update exposes this pre-existing file mismatch environment to the degree that IIS is now unable to function properly.

Resolution

As a quick remedy, uninstall the update for Windows Server 2003 – KB973917.
However, the suggested method is to reinstall Service Pack 2 for Windows Server 2003 on the web server.


References
http://support.microsoft.com/Default.aspx?kbid=2009746