Intelligent Updater is not working with Symantec Scan Engine 5.2 installed on 64-bit Operating System.

book

Article ID: 178138

calendar_today

Updated On:

Products

Scan Engine

Issue/Introduction

The Intelligent Updater (IU) provided by Symantec Security Response for the Symantec Scan Engine 5.2 product does not run on a 64-bit operating system.

 


 

When Intelligent Updater for Symantec Scan Engine (SSE) is executed, it will report that it is incompatible with a 64-bit version OS.

Cause

Symantec's Security Response currently does not provide a 64-bit version of the Intelligent Updater compatible with Symantec Scan Engine.  IU's are available for 32-bit platform and Unix platforms.

 

Resolution

One possible procedure to update the definitions:

  1. Enable the Symantec Scan Engine setup-iu.bat (shadow IU), 'setup-iu.bat' is located under /Definitions/AntiVirus/ in the Symantec Scan Engine install directory.  To enable this run the command "setup-iu.bat enable". 
  2. If not already present, create the path, "C:\Program Files\Common Files\Symantec Shared\VirusDefs\CSAPIDefs\".
  3. Download the SAVCE Intelligent Updater/Rapid Release executable from Security Response. The file name will have the format 'YYYYMMDD-nnn-i32.exe'.
  4. Run the command, "symrapidreleasedefsi32.exe /EXTRACT /Q . The "path" depends on the OS, on Windows this path will be "C:\Program Files\Common Files\Symantec Shared\VirusDefs\CSAPIDefs". So the command would be,
    'YYYYMMDD-nnn-i32.exe' /EXTRACT /Q "C:\Program Files\Common Files\Symantec Shared\VirusDefs\CSAPIDefs"'.
  5. Give Scan Engine a minute, and confirm via the Symantec Scan Engine GUI that the definitions have been updated. 

 

An additional workaround would be to setup an internal LiveUpdate Administrator 2.x server, and configure SSE's LiveUpdate client to retrieve virus definitions from this LUA 2.x server.  

 

An enhancement request (Connect Forum "Idea") has been proposed for an IU that updates 64-bit SSE.  For more details, and to express your opinion for or against such a product, please visit the Intelligent Updater Needed for 64-Bit Scan Engine entry in Connect, Symantec's peer-support forums