Symantec Endpoint Protection (SEP) Installation fails with Error "AMS -- Internal Error 2753. InstallAMS.dll"
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Symantec Endpoint Protection (SEP) Installation fails with Error "AMS -- Internal Error 2753. InstallAMS.dll"

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Article ID: 178057

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Updated On:

Products

Endpoint Protection

Issue/Introduction

Why does the Symantec Endpoint Protection client installtion fail?

Symptoms
SEP_Inst.log details :


MSI (s) (D4:98) [10:36:10:445]: Doing action: MSIUnInstallAMSServerLegacy.F4413C06_9100_4CCA_959E_AAC27B587C0D
Action ended 10:36:10: MSISTS_INITIAL_MESSAGE.F4413C06_9100_4CCA_959E_AAC27B587C0D. Return value 1.
Action start 10:36:10: MSIUnInstallAMSServerLegacy.F4413C06_9100_4CCA_959E_AAC27B587C0D.
MSI (s) (D4:98) [10:36:10:461]: Doing action: MSIUnInstallAMS.F4413C06_9100_4CCA_959E_AAC27B587C0D
Action ended 10:36:10: MSIUnInstallAMSServerLegacy.F4413C06_9100_4CCA_959E_AAC27B587C0D. Return value 1.
MSI (s) (D4:98) [10:36:10:461]: Note: 1: 2753 2: InstallAMS.dll.F4413C06_9100_4CCA_959E_AAC27B587C0D
Action start 10:36:10: MSIUnInstallAMS.F4413C06_9100_4CCA_959E_AAC27B587C0D.
DEBUG: Error 2753: The File 'InstallAMS.dll.F4413C06_9100_4CCA_959E_AAC27B587C0D' is not marked for installation.
MSI (s) (D4:98) [10:36:10:461]: Product: AMS -- Internal Error 2753. InstallAMS.dll.F4413C06_9100_4CCA_959E_AAC27B587C0D

Internal Error 2753. InstallAMS.dll.F4413C06_9100_4CCA_959E_AAC27B587C0D
MSI (s) (D4:98) [10:36:10:476]: Machine policy value 'DisableRollback' is 0
MSI (s) (D4:98) [10:36:10:492]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (D4:98) [10:36:10:492]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (D4:98) [10:36:10:508]: No System Restore sequence number for this installation.
MSI (s) (D4:98) [10:36:10:508]: Unlocking Server
Action ended 10:36:10: MSIUnInstallAMS.F4413C06_9100_4CCA_959E_AAC27B587C0D. Return value 3.

Cause

AMS2 installation is corrupt and causes this to happen.

Resolution


Open Add/Remove Programs and try uninstalling AMS - If successful, try installing Symantec Endpoint Protection again.
If you are unable to remove AMS in this manner perform the following steps listed below.


Note : Please backup the registry before making any changes to it.
  • Open Registry Editor - Backup the registry
  • Navigate to HKEY_LOCAL_MACHINE\SOFWARE\Intel\LANDesk\AMS2
  • Delete AMS2
  • Use the Windows Installer Cleanup Utility to remove AMS2
  • Installing Symantec Endpoint Protection client.