Auto-upgrade of Symantec Endpoint Protection fails due to a HTTP 404.3 error

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Article ID: 177996

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Updated On:

Products

Endpoint Protection

Issue/Introduction

You are migrating your SEP clients from an older release to a newer one via the auto-upgrade feature, but it fails.
 

Error 404 appears in the sylink.log and error 404.3 in the server's IIS log when the clients attempt to download the delta package from the management server (SEPM).
 

Cause

404.3 - MIME Map policy prevents this request. This problem occurs if the following conditions are true: 1. The handler mapping for the requested file name extension is not configured. 2. The appropriate MIME type is not configured for the Web site or for the application. It can happen when the Symantec virtual folders have been moved in a new web site under IIS but the required file name extensions are not put in place.

Resolution

You have to check if the required name extensions are in place:

  1. Open IIS
  2. Open the Properties of the Symantec Web site in use
  3. Select the HTTP Headers and click on the MIME Types button
  4. Check if the following file name extensions are in place:
    .bat, .cfg, .dat, .dax, .db, .grd, .hst, .ini, .kc, .loc, .manifest, .plg, .policy, .reg, .rul, .sig, .spm, .sys, .wlt.
  5. Click OK and apply the changes to the virtual folders as well.


http://support.microsoft.com/kb/318380


Technical Information
Here are the MIME type configurations for the Symantec Web Server.


.bat, Batch File
.cfg, Configuration File
.dat, DAT File
.dax, application/x-SymantecEndpointProtectionManager
.db, DB File
.grd, GRD File
.hst, HST File
.ini, Configuration Settings
.kc, KC File
.loc, LOC File
.manifest, MANIFEST File
.plg, PLG File
.policy, Policy File
.reg, REG File
.rul, RUL File
.sig, SIG File
.spm, SPM File
.sys, SYS File
.wlt. WLT File