Preparing a Symantec Endpoint Protection Release Update 5 and above Client for Image redistribution

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Article ID: 177991

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Updated On:

Products

Endpoint Protection

Issue/Introduction

How can I prepare a SEP 11 RU5 (or greater) client for distribution via Computer Image?

Symptoms

  • Simply imaging a client "as is" will not generate a new Hardware ID.
  • Emptying the HardwareID Key will not generate a new Hardware ID.

Cause

RU5 changes the way the Identifier for the Client (Hardware ID) is generated. Now it is based on a Registry Key and a XML File. In previous Versions it relied only on the Registry Value.

Resolution


In order to prepare the client for the image, it is vital that you follow these steps:

  1. Empty the Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec Endpoint Protection\SMC\SYLINK\SyLink\HardwareID=""
  2. Delete the file: C:\Program Files\Common Files\Symantec Shared\HWID\sephwid.xml
  3. If present, delete: HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec Endpoint Protection\SMC\SYLINK\SyLink\SySoftk
  4. Prevent a restart of the original host before creation of the image (shutdown is OK, but after startup both Key and File will be re-created)


After applying the Image the client will be started and the Registry Key and File newly created.

How to fix RU5 clients that have been incorrectly configured and already rolled out to production (For each client:)

  1. Delete %programfiles%\Common Files\Symantec Shared\HWID\sephwid.xml
  2. Open the registry and navigate to HKLM\Software\Symantec\Symantec Endpoint Protection\SMC\SYLINK\SyLink
  3. Edit the "HardwareID" value data to be blank
  4. Restart the Symantec Management Client (SMC) service in the services snap-in.


Clients should now generate unique HardwareID's and sephwid.xml's.

References

'Configuring Symantec Endpoint Protection client for deployment as part of a drive image'
http://www.symantec.com/business/support/index?page=content&id=TECH102815