LiveUpdate fails with error code 1814 although proxy settings are correct
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LiveUpdate fails with error code 1814 although proxy settings are correct

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Article ID: 177920

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Updated On:

Products

Endpoint Protection

Issue/Introduction

The Symantec Endpoint Protection Manager (SEPM) accesses the Internet through a proxy server. After proxy settings have been configured via the SEPM console, LiveUpdate fails with error code 1814. How can this be resolved?

Symptoms
You may find log.liveupdate has similar words as below:

2009/9/9, 03:11:25 GMT -> Progress Update: TRYING_HOST: HostName: "liveupdate.symantec.com" URL: "http://liveupdate.symantec.com" HostNumber: 1
2009/9/9, 03:11:25 GMT -> Progress Update: DISCONNECT
2009/9/9, 03:11:25 GMT -> Progress Update: TRIFILE_DOWNLOAD_START: Number of TRI files: 0 Downloading LiveUpdate catalog file
2009/9/9, 03:11:25 GMT -> LiveUpdate will download the first Mini-TRI file, liveupdate_3.3.0.85_english_livetri.zip
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_BATCH_START: Files to download: 1, Estimated total size: 0
2009/9/9, 03:11:25 GMT -> Progress Update: PRE_CONNECT: Proxy: "http=proxy2.*.com:8080" Agent: "jd6ONVKqam1KAMsy1XdoQpKYY9gqhynSgAAAAA" AccessType: 0x3
2009/9/9, 03:11:25 GMT -> Progress Update: CONNECTED: Proxy: "http=proxy2.*.com:8080" Agent: "jd6ONVKqam1KAMsy1XdoQpKYY9gqhynSgAAAAA" AccessType: 0x3
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_FILE_START: URL: "http://liveupdate.symantec.com/liveupdate_3.3.0.85_english_livetri.zip", Estimated Size: 0, Destination Folder: "C:\Documents and Settings\All Users\Application Data\Symantec\LiveUpdate\Downloads"
2009/9/9, 03:11:25 GMT -> CSendHTTPRequest::SendRequest - The network or a proxy server is attempting to redirect LiveUpdate's connection.
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_FILE_FINISH: - NOTE - URL: "http://liveupdate.symantec.com/liveupdate_3.3.0.85_english_livetri.zip", Full Download Path: "C:\Documents and Settings\All Users\Application Data\Symantec\LiveUpdate\Downloads\liveupdate_3.3.0.85_english_livetri.zip" HR: 0x802A0060
2009/9/9, 03:11:25 GMT -> HR 0x802A0060 DECODE: E_INTERNET_REDIRECT
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_BATCH_FINISH: HR: 0x0 , Num Successful: 0
2009/9/9, 03:11:25 GMT -> LiveUpdate will check for Mini-TRI file support on the server since the first Mini-TRI file was not available (liveupdate_3.3.0.85_english_livetri.zip).
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_BATCH_START: Files to download: 1, Estimated total size: 0
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_FILE_START: URL: "http://liveupdate.symantec.com/minitri.flg", Estimated Size: 0, Destination Folder: "C:\Documents and Settings\All Users\Application Data\Symantec\LiveUpdate\Downloads"
2009/9/9, 03:11:25 GMT -> CSendHTTPRequest::SendRequest - The network or a proxy server is attempting to redirect LiveUpdate's connection.
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_FILE_FINISH: - NOTE - URL: "http://liveupdate.symantec.com/minitri.flg", Full Download Path: "C:\Documents and Settings\All Users\Application Data\Symantec\LiveUpdate\Downloads\minitri.flg" HR: 0x802A0060
2009/9/9, 03:11:25 GMT -> HR 0x802A0060 DECODE: E_INTERNET_REDIRECT
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_BATCH_FINISH: HR: 0x0 , Num Successful: 0
2009/9/9, 03:11:25 GMT -> Progress Update: TRIFILE_DOWNLOAD_END: Number of TRI files: "0"
2009/9/9, 03:11:25 GMT -> Progress Update: TRIFILE_DOWNLOAD_START: Number of TRI files: 1 Downloading LiveUpdate catalog file
2009/9/9, 03:11:25 GMT -> LiveUpdate could not find the MiniTri.flg file on the server. LiveUpdate is entering legacy mode and will attempt to download the full LiveUpdate Catalog file.
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_BATCH_START: Files to download: 1, Estimated total size: 0
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_FILE_START: URL: "http://liveupdate.symantec.com/livetri.zip", Estimated Size: 0, Destination Folder: "C:\Documents and Settings\All Users\Application Data\Symantec\LiveUpdate\Downloads"
2009/9/9, 03:11:25 GMT -> CSendHTTPRequest::SendRequest - The network or a proxy server is attempting to redirect LiveUpdate's connection.
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_FILE_FINISH: - NOTE - URL: "http://liveupdate.symantec.com/livetri.zip", Full Download Path: "C:\Documents and Settings\All Users\Application Data\Symantec\LiveUpdate\Downloads\livetri.zip" HR: 0x802A0060
2009/9/9, 03:11:25 GMT -> HR 0x802A0060 DECODE: E_INTERNET_REDIRECT
2009/9/9, 03:11:25 GMT -> Progress Update: DOWNLOAD_BATCH_FINISH: HR: 0x0 , Num Successful: 0
2009/9/9, 03:11:25 GMT -> Progress Update: TRIFILE_DOWNLOAD_END: Number of TRI files: "1"
2009/9/9, 03:11:25 GMT -> EVENT - SERVER SELECTION FAILED EVENT - LiveUpdate failed to connect to server liveupdate.symantec.com at path via a HTTP connection. The server connection attempt failed with a return code of 1814, LiveUpdate could not retrieve the catalog file of available Symantec product and component updates.

Cause

The proxy server uses HTTPS protocol (SSL) to authorize credentials for all clients. When LiveUpdate connects via proxy, the connection is redirected to another HTTPS connection to authorize credentials, but LiveUpdate doesn't support redirected connections.

Resolution

Manually login to the proxy server the first time you run LiveUpdate.