Taskbar disappears upon every logon on the Citrix server after installing SEP

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Article ID: 177869

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Updated On:

Products

Endpoint Protection

Issue/Introduction

Why does the Taskbar disappear upon every logon on the Citrix server after installing SEP ?

Symptoms
The Taskbar Disappears as soon as the user logs on to the Citrix server. It only displays a thin bar at the bottem of the screen which needs to be Dragged/Pulled in order to see the Start button and Sytem tray Icons


Cause

Issue with SmcGui.exe corruption

Resolution


Step One
  1. Click Start, click on Run
  2. Type “Smc –stop”, then click OK. Enter a Password if Prompted
  3. Wait for the Shield to disappear from the System tray
  4. Browse to the SEP Client installation location (Default location C:\Program Files\Symantec\Symantec Endpoint Protection)
  5. Find the file SmcGui.exe and right click it and click Rename
  6. Rename the file “xSmcGui.exe” press Enter
  7. Create new text file and rename the file to SmcGui.exe and place it to (Default location C:\Program Files\Symantec\Symantec Endpoint Protection)



Step Two
  1. Click Start, click on Run
  2. Type “regedit” then click OK
  3. For 32-bit go to HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run, for 64-bit go to HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run
  4. Back up ccApp key just in case you need it later - then delete it!
  5. Click Start, click on Run
  6. Type “Smc –stop”, then click OK



References
Best Practices for Symantec Endpoint Protection on Citrix and Terminal Servers

http://service1.symantec.com/support/ent-security.nsf/docid/2008112414453348