Outbound messages are not delivered to some domains Messaging Gateway
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Outbound messages are not delivered to some domains Messaging Gateway

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Article ID: 177739

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Messages are accumulating in the delivery queue for some domains and cannot be delivered from Symantec Messaging Gateway (SMG).

Viewing the delivery queue, messages are queued with the status "450 4.7.1: Helo command rejected: Host not found".

 

 

450 4.7.1: Helo command rejected: Host not found

Environment

Messaging Gateway

Cause

Mail servers may perform a DNS check to resolve the hostname provided by the sender in the SMTP EHLO command and defer the connection if the IP for the EHLO hostname either does not exist or does not match the connecting IP.

This is similar to the the SMG DNS validation option "Reject connections where the domain provided at HELO and EHLO has neither an 'A', nor an 'AAAA', nor an 'MX' record in DNS"

 

Resolution

Ensure that the MTA hostname has an associated DNS address record and that the SMG public IP matches the DNS address record.

To change the MTA host name:

  1. Login to the Control Center
  2. Click the Administration Tab
  3. Navigate to -> Hosts -> Configuration
  4. Click on the scanner(s) having the problem to open its configuration
  5. Click the SMTP Tab -> Scroll down and click on Advanced Settings
  6. Change the "MTA host name" to match the MX record found in the nslookup. (in this example it will be: "mail.example.com")
  7. Click Continue
  8. Click Save

Once the changes are applied, retry the mail delivery:

  1. Navigate to Status -> SMTP -> Message Queues
  2. On the right-hand side select the Host you just changed, change the queue to "Delivery", change the list to "All"
  3. Click Display Filtered
  4. Select the messages you want to retry
  5. Click Flush