"purging domain" and "used as an MX route" warning messages on Symantec Messaging Gateway
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"purging domain" and "used as an MX route" warning messages on Symantec Messaging Gateway

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Article ID: 177676

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Updated On:

Products

Messaging Gateway

Issue/Introduction

When reviewing the Messaging Gateway MTA logs, the following messages warn of Messaging Gateway attempting to use an IP address as an email / MX route:

2019 May 14 07:01:31 PDT (warning) ecelerity: [20867] smsrouting: ip address '10.10.10.1' used as an MX route
2019 May 15 14:43:21 PDT (info) ecelerity: [27244] smsrouting: purging domain #sms#00000003

Cause

"used as an MX route" indicates that an IP address was used for MX lookup during delivery.  Example: If a message is sent using the outbound queue for an address like "[email protected]" this message will show up in the logs.

NOTE: After the first message the lookup will be cached so if it's necessary to reproduce it again then restart the MTA before doing so.

"purging domain" indicates a domain record for a domain is being added that has broken routing information, meaning that an NXDOMAIN response has been received.   Example: A domain that has a broken MX record. If nslookup is run against the given domain the following response should be seen:  ** server can't find domain.test: NXDOMAIN

 

Resolution

These messages do not indicate a problem with Messaging Gateway, only that Messaging Gateway is attempting to deliver a message which has used an IP address as the destination domain rather than a valid MX domain or properly bracketed IP address. 

If there are a large number of these warnings in the MTA logs, there may be one or more application servers on the internal network which are not configured to send to properly formatted email addresses.