Mail to a particular domain is stuck in your Delivery Queue with error: "450 4.7.1 <recipient address>... recipient denied" for a Symantec Brightmail Gateway version 8.0 and above

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Article ID: 177647

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Updated On:

Products

Messaging Gateway

Issue/Introduction

When the receiving mail server is employing an antispam measure known as "Sender Address Verification," and a Symantec Brightmail Gateway (SBG) version 8.0 and above has "Connection Classification" enabled, some e-mail messages may get stuck in the Delivery Queue with the error code "450  4.7.1" and an error indicating that a recipient of those e-mail messages has been denied.

Messages are stuck in the queue with errors similar to this:

450 4.7.1 ... recipient denied, because MX 10 \'.\' did not accept the empty address, <>, as required by RFC 821, 1123, 2505, and 2821

Cause

The receiving mail server is employing an antispam measure known as "Sender Address Verification". The IP address of the server attempting the verification is in a "Connection Classification"  class that does not allow many simultaneous connections or messages.  An SBG appliance does accept the empty address <> as required by RFCs.

Resolution

To resolve this issue, do one of the two things:

  • Edit the "Default" Connection Classification to allow more Connections per IP and Messages per Connection    OR 
  • Disable "Connection Classification", which can be found under Reputation -> Policies -> Connection Classification, on the "Connection Classification" page on the web graphical user interface (gui) of a SBG appliance's also known as the Control Center.

Note: Most sending MTAs will fall into the "Default" classification, so it is not recommended to increase these values too much. Symantec cannot provide specific values because the default values are considered best practice.  Any changes to the default values should take into consideration environmental factors such as the inbound mail volume.