The Update Status in Symantec Mail Security for Microsoft Exchange shows "Rapid Release Update was unable to complete successfully due to an FTP error"
search cancel

The Update Status in Symantec Mail Security for Microsoft Exchange shows "Rapid Release Update was unable to complete successfully due to an FTP error"

book

Article ID: 177521

calendar_today

Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

Note - these steps are only for SMSMSE 7.5.2 or newer. If you are having issue with a version prior to 7.5.2 please refer to http://www.symantec.com/docs/TECH233744

You see that the Update Status in Symantec Mail Security for Microsoft Exchange shows "Rapid Release Update was unable to complete successfully due to an FTP error". What is causing this problem?

Symptoms
Rapid Release runs either manually or scheduled.

  • LiveUpdate may work.
  • The file "Rapidreleasex64.bat" contains no errors and can be started manually.
  • The file "RRx64" contains the correct path to symrapidreleasedefscore15-v5i32.exe.
  • There are no processes called ftp.exe, symrapidreleasedefscore15-v5i32.exe in Task manager.
  • An FTP session in DOS to ftp.symantec.com results in "...host cannot be found"



 

Cause

The problem is with either name resolution on the proxy, or with the proxy itself.

Resolution

Various solutions exist, depending on the exact cause of the problem.

If the proxy cannot resolve "ftp.symantec.com":

  • Bypass the proxy.
  • Fix the name resolution on the proxy.


If the Exchange Server fails to connect to the proxy over ftp:

  • Get the proxy sorted: check whether the necessary services are running on the proxy.
  • Get the network sorted.


If the above does not describe the problem with Rapid Release definitions, please have a look at this document:
'Rapid Release updates crash, report an error code of 0 or stay stuck at "Running"'
http://www.symantec.com/docs/TECH90895




Technical Information
One way of testing where the issue is, is to open a DOS box on the Exchange server and try to connect to ftp.symantec.com

 

  1. Open a Command prompt.
  2. At the command line type
    ftp
  3. An FTP session will be opened. Now enter the following commands, one line at a time, and press the enter-key on your keyboard
    open ftp.symantec.com
  4. You will now see: "Connected to 25280.ftp.download2.akadns.net." (or a similar host) followed by "220 spftp/1.0.0000 Server [xx.xx.xx.xx]" (where xx.xx.xx.xx is an IP address)
  5. You will be asked for a user name: "User (25280.ftp.download2.akadns.net:(none)):". The user name is
    anonymous
  6. The next line asks for the password, which is
    [email protected]
  7. Once you are in, a WARNING appears (4 or 5 lines starting with '230'). On the next line type:
    cd public/english_us_canada/antivirus_definitions/norton_antivirus_corp/rapidrelease/
  8. The response should be "250 CWD command successful". Then type:
    binary
  9. The response should be "200 TYPE set to I". Then type:
    prompt
  10. The expected response is "Interactive mode Off". Then type:
    get symrapidreleasedefscore15-v5i32.exe
  11. The expected response is "200 PORT command successful."
  12. "150 Opening BINARY mode data connection for symrapidreleasedefsi32.exe (42746200 bytes)."
  13. After some time you should see "226 Transfer Complete" plus a line specifying the number of bytes received and the speed.
  14. You can then close the ftp session by typing:
    quit