Email message is being deleted with the Blocked Language
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Email message is being deleted with the Blocked Language

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Article ID: 177394

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Messaging Gateway is blocking one or more messages with the verdict Blocked Language but on cursory inspection of the message it appears to be in an allowed language. 

Cause

This is usually occurs with messages which have a mixture of language content in either the headers, body, or attachment content. Language identification is based on a number of factors including an explicit language or character set specification in the message headers or body html, a mixture of characters from different character sets which visually appear to be from an allowed character set but are note, or other character set factors flag the message as containing a significant fraction of language from disallowed character sets. Often SMG has to make a "best guess" regarding a message's language which may not always match the visual representation of the email in a mail client or browser.

Often forwarded messages or message chains can contain alternate language content as part of the forward chain that does not appear in earlier parts of the message.

Resolution

The following options are available to address the issue:

  • Create a policy group in Administration > Policy Groups for recipients who do not require language identification or who frequently receive messages with disallowed language content
  • Disable Language Identification settings in the Default or affected Policy Group to allow for additional languages
  • Request the Sender of the problematic email to trim unneccesary forward history from the message body and resend the message


Note: If  "Specify language settings" is enabled for the end users, you may need to disable it globally in Administration > Users > Policy Groups > End Users