LiveUpdate was unable to complete successfully With Error Code 1845: "The PreSession callback for product SMSMSE Virus Definitions completed with a result of 0x80004005"

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Article ID: 177379

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

Symantec Mail Security for Microsoft Exchange (SMSMSE) generates an Alert Notification "LiveUpdate was unable to complete successfully," but the virus definitions are updated.


Symantec Endpoint Protection (SEP) or Symantec AntiVirus (SAV is installed on the server.

  • Log.Liveupdate contains the following error codes:

    -- 0x80004005
    -- error code 1845

 



 

Cause

This error can have multiple causes.

Resolution

If Liveupdate is enabled for both Symantec Endpoint Protection (SEP) or Symantec AntiVirus (SAV) and SMSMSE

  1. Enable LiveUpdate only for Symantec Endpoint Protection (SEP) or Symantec AntiVirus (SAV)
  2. Disable LiveUpdate in SMSMSE.
      1. Open the SMSMSE Console
      2. Go to Admin
      3. Go to Liveupdate/Rapid Release Schedule
      4. Uncheck "Enable automatic virus definitions updates"
  3. For more details, please follow the document Configuring LiveUpdate for multiple Symantec products installed on the same computer.
  4. If disabling Liveupdate in SMSMSE (and at the same time enabling Liveupdate in SEP/SAV) does not resolve the error, proceed with the next section.


Rename the Downloads folder

  1. Log on to the Exchange server on which SMSMSE is installed.
  2. Open Windows Explorer.
  3. Go to the folder Liveupdate in C:\Documents and Settings\All Users\Application Data\Symantec\LiveUpdate (default path).
  4. The folder Liveupdate contains a subfolder called Downloads. Rename the folder to _Downloads.
  5. The next scheduled Liveupdate, by SEP, should no longer generate error messages in Log.Liveupdate or Alert Notifications from SMSMSE.


Deregister SMSMSE from LiveUpdate to allow SEP/SAV to retrieve updates

  1. Open a command prompt (Start -> Run, cmd).
  2. Navigate to the SMSMSE directory (cd <installdrive>:\Program Files\Symantec\SMSMSE\<version>\Server).
  3. Run the following command: regsvr32 /u savfmselu.dll.
  4. LiveUpdate should now complete successfully with no 1845 error observed.

 

 


Technical Information
Log.Liveupdate file shows entries similar to:

......................
10/13/2008, 4:46:52 GMT -> LiveUpdate is about to launch a new callback proxy process for product SMSMSE Virus Definitions with moniker {F92F8A7B-F111-4db7-B145-6C41E7D6AE94}.
10/13/2008, 4:46:52 GMT -> The callback proxy for moniker {F92F8A7B-F111-4db7-B145-6C41E7D6AE94} was successfully registered with LiveUpdate.
10/13/2008, 4:46:52 GMT -> LiveUpdate successfully launched a new callback proxy process for product SMSMSE Virus Definitions.
10/13/2008, 4:46:52 GMT -> LiveUpdate is about to execute a PreSession callback for product SMSMSE Virus Definitions.
10/13/2008, 4:46:52 GMT -> The callback failed with a return code of 0x80004005
10/13/2008, 4:46:52 GMT -> The PreSession callback for product SMSMSE Virus Definitions completed with a result of 0x80004005
10/13/2008, 4:46:52 GMT -> LiveUpdate aborted product SMSMSE Virus Definitions for the following reason (error code 1845), This product was not updated due to a processing error.
10/13/2008, 4:46:52 GMT -> Successfully released callback {0D7E9ED3-A063-4BB1-B3E6-E826F5D68306}
10/13/2008, 4:46:52 GMT -> LiveUpdate has called the last callback for product SMSMSE Virus Definitions, so LiveUpdate is informing the callback proxy that it can exit.
................


 


Applies To

  •         Operating System is 32 bit.

        This KB does not apply for Exchange 2007 or Exchange 2010