Footprint compromised errors (C1G0119E and ENDE092E) on base or delta members
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Footprint compromised errors (C1G0119E and ENDE092E) on base or delta members

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Article ID: 17737

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Updated On:

Products

Endevor

Issue/Introduction

Footprint compromised errors can be displayed during source management of an element action.
These errors can appear on either base or delta files members.

 



Environment

All Supported Releases 

Cause

The link between Master Control Files (MCF), Base and Delta files has been broken meaning that the files are no longer synchronized.
This errors can happen if the Base, Delta, or MCF have been restored or copied but are not synchronized.
This can also happen if the base or delta member have been edited outside of Endevor.
The message text is: C1G0119E FOOTPRINT COMPROMISED (or ENDE092E Source Management Error) and it notes the base or delta file.


If other files are noted, that is a different problem

Resolution

If the file is a Base or Delta file,

Check that element can be restored from existing Endevor Backup.

  • If there is no backup, copy the Base element to an external PDS. (Note - If the Type definition has DELTA FORMAT set to Reverse, Full image delta format, or Log delta format, the current version is in the base)    
  • Try deleting the element in batch SCL action, errors message will be issued, but the element will be deleted.  

After delete, possible action is depending on the backup availability.

  • If Endevor Backup exists, possible action are Restore, Transfer from archive the element to the wanted location
  • If there is no Endevor backup, Add the element from an external PDS, then move it to the wanted location.
  • If that does not resolve the problem, the base, delta and master control file need to be synchronized.
  • If any one of these files is out of sync with the other files, error message are issued.

Running the Unload, Reload, Validate utility (iprfx.iqual.CSIQJCL(BC1JVALD)) in validate will identify the problematic elements. 

This will not resolve the problem, but it will provide diagnostic information. 
The solution will depend on the cause and extent of the problem, then Contact support.

Additional Information

Going forward should run a UNLOAD periodically and run a VALIDATE on a regular basis. This using the Unload, Reload, and Validate utility. The UNLOAD or the VALIDATE will detect these errors.