Error: "No valid Sensors in Working group"
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Error: "No valid Sensors in Working group"

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Article ID: 177316

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Updated On:

Products

Security Information Manager

Issue/Introduction



Symptoms
You have installed a collector but it is not working. You have looked at the collector logs and see this error:

"No Valid sensors in working group !"


Cause

A collector configuration has not been created, or has not been distributed to the Event Agent on the collector computer. OR The Syslog Director was upgraded to 4.3, but the upgrade did not finish successfully. This will generate these errors in the syslogdirector.log

Resolution

For each collector a new configuration needs to be created and distributed to the Event Agent on the collector computer.

Verify Syslog Director 4.3 was installed successfully

Log into the HTTPS Configuration page.
In the left pane, click System Updates
In the right pane, find the Syslog Director 4.3 upgrade.
If it is not listed, or listed with anything other than Success, the Syslog Director 4.3 upgrade package must be installed again.

Verify Settings
If this is not the syslog director, or the syslog director was installed successfully, verify your settings.

Log in to the SSIM console
Select the Product configurations tab
Drill down to the collector you are working with
Under the collector you should see the active configuration listed under (in addition to) the "Default" configuration.

If you don't have a configuration other than default, you need to create a new configuration, add the collector computer to the configuration, configure and activate the sensor, and distribute it.

1) Right click the collector
2) Choose new. (The New configuration wizard will appear)

3) Provide the configuration with a name, then click next
4) Click "Add", then choose the computer with the collector installed, add it to the selected computers list, then click OK, then Next, then Finish, then Close.
Note: If the collector is installed on the SSIM itself, select the SSIM, then click next, otherwise select the computer that has the collector installed. If you do not see the collector computer listed, then the agent or collector is not installed, or it may be isolated by a firewall or similar device.

5) Click on the new configuration
6) Select the far right tab to display the Sensor settings (the name varies depending on which collector you are using)
7) Make sure that the values in the sensor configuration are correct according to the guide that came with the collector
8) Check the box next to the sensor to activate it, then click Save.

9) Right Click the new configuration
10) Choose Distribute, then Yes to confirm.


If you already have created a new configuration for your selected collector, make sure the correct computer is added to the collector configuration and distributed.
1) Right click the active configuration for the collector
2) Choose properties
3) Select the "Computers" tab - make sure the appropriate computer is listed. If it is not listed, you need to add it by following steps 4-10 above.

If the correct computer is selected make sure the sensor is configured properly. Select the new configuration and follow steps 6-10 above.

If the Sensor is already correctly configured, and activated (checked), make sure the configuration is distributed, steps 9 and 10 above. If you make any changes to the Sensor or collector configuration it is necessary to Distribute the configuration again. note that you must distribute the configuration even if the collector is installed on the appliance itself.