Error: "java.net.ConnectException: Connection timed out: connect" while retrieving virus definitions in an environment with a proxy server
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Error: "java.net.ConnectException: Connection timed out: connect" while retrieving virus definitions in an environment with a proxy server

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Article ID: 177295

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Updated On:

Products

Scan Engine

Issue/Introduction

When you click "LiveUpdate Content" in the web interface of Symantec Scan Engine 5.x, the LiveUpdate status becomes "LiveUpdate In Progress", then changes to "Unable to Update". You seek to overcome this obstacle and retrieve virus definitions by clicking "LiveUpdate Content" in the web interface of Scan Engine going forward.

Symptoms
Look for more information in the Liveupdt.log file.

The location of Liveupdt.log is:

For Windows,
\Documents and Settings\All Users\Application Data\Symantec\Java Liveupdate


For Windows 2008:

\ProgramData\Symantec\Java Liveupdate\

For Unix,

/opt/Symantec/liveupdt/

The lines you may find in the Liveupdt.log:
02.05.2008 06:01:10 Connecting to liveupdate.symantec.com:80 via HTTP ...
02.05.2008 06:01:33 java.net.ConnectException: Connection timed out: connect
...

etc. (after a fixed amount of seconds)

And the log file ends with:
02.05.2008 06:02:19 A LiveUpdate server could not be selected.
02.05.2008 06:02:19
02.05.2008 06:02:19 The Java LiveUpdate session did not complete successfully.
02.05.2008 06:02:19 Return code = -2.001
02.05.2008 06:02:19



 

Cause

By default, Scan Engine is configured to use Symantec LiveUpdate servers to get updates. If you are retrieving updates through HTTP and your network configuration requires all Internet requests to proxy through another server, you must specify those proxy settings in the LiveUpdate configuration file.

Resolution

To specify a proxy server:

Locate the liveupdate configuration file (liveupdate.conf).

In Windows,
\Documents and Settings\All Users\Application Data\Symantec\Java Liveupdate

In Windows 2008:

\ProgramData\Symantec\Java Liveupdate\liveupdate.conf

In Unix,
/opt/Symantec/liveupdt/ or
/etc/


For Scan Engine 4.x
You can edit liveupdate.conf and add the following lines to the bottom of the file (each on their own line)

proxy=<IP of proxy server>
proxyport=<port of proxy server>
proxyusername=<username>
proxypassword=<password>


For Scan Engine 5.x
You can edit liveupdate.conf and add the following lines to the bottom of the file (each on their own line)
 

proxy=<IP of proxy server>:<port of proxy server>
proxyusername=<username>
proxypassword=<password>



At proxy= type the proxy server host name or IP address and the port number (separated by a colon).
You must use the following format: <servername>:<portnumber>
where <servername> is the IP address or host name of the proxy server, and <portnumber> is the appropriate port.

NOTE: The proxyusername and proxypassword are optional. If you do not need to specify a user name and password then do not add those lines.

Restart the Symantec Scan Engine service to apply the updated changes:

In Windows this can be accomplished by using Administrative Tools / Services, right click on the Symantec Scan Engine service, and choose restart.

For unix issuing the following command at a terminal prompt "/etc/init.d/symcscan restart" will force a restart of the Symantec Scan Engine daemon.