The Symantec Mail Security for Microsoft Exchange (SMSMSE) Installation Rolls Back When COM Permissions not Enabled for Interactive Account
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The Symantec Mail Security for Microsoft Exchange (SMSMSE) Installation Rolls Back When COM Permissions not Enabled for Interactive Account

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Article ID: 177288

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

The installer for SMSMSE is run.  It does not complete and rolls back.

Conditions

  • MSI Installer log shows error message "Entrypoint: fnStubGetProcessCount"

1. Turn on MSI debugging using this article:  Obtaining detailed installation logging for the installed Symantec Mail Security for Microsoft Exchange product.

2. Open the MSI log file and look for the following entries:

 

 


Action 15:41:06: fnStubGetProcessCount.
Action start 15:41:06: fnStubGetProcessCount.
MSI (c) (3C:F0) [15:41:06:587]: Invoking remote custom action. DLL: C:\DOCUME~1\mmbc\LOCALS~1\Temp\MSI5144.tmp, Entrypoint: fnStubGetProcessCount
Action ended 15:41:06: fnStubGetProcessCount. Return value 3.
MSI (c) (3C:60) [15:41:06:900]: Doing action: SetupCompleteError

 

 

The presence of these error message indicates this condition. 

  • COM permissions are not set for Interactive user.

1. Start the DCom Configuration application (Start -> Rundcomcnfg).

2. From left side pane, select node Console Root > Component Services > Computers > My Computer > DCOM Config.

3. Click on button Configure My Computer on the application toolbar.

4. Select tab COM Security.

5. Click on Edit Defaults button present in Access Permissions group box.

6. If the accounts INTERACTIVE and SYSTEM user accounts are not listed under Default Security list then this condition is met.

Cause

Default COM access permissions are not set for the Interactive account.

Resolution

Add the accounts to the COM permissions.

1. Start the DCom Configuration application (Start > Run > dcomcnfg).

2. From left side pane, select node Console Root > Component Services > Computers > My Computer > DCOM Config.

3. Click on button Configure My Computer on the application toolbar.

4. Select tab COM Security.

5. Click on Edit Defaults button present in Access Permissions group box.

6. If the accounts INTERACTIVE and SYSTEM user accounts are not listed under Default Security list then this condition is met.

7. Add these two user accounts to 'Default Security' list if they are not there already.