The simdbmu service fails to start
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The simdbmu service fails to start

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Article ID: 177267

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Updated On:

Products

Security Information Manager

Issue/Introduction



Symptoms
The simdbmu service fails to start. When you look at the log file /opt/Symantec/simserver/simdbmu/simdbmu.log, you see this error:


[DBMU] ERROR com.symantec.sim.simdb.Main - failed to initialize application
org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Connection authorization failure occurred. Reason: User ID or password invalid.)

 

Cause

The simdbmu service stores the db2admin's username and password in the /opt/Symantec/simserver/simdbmu/simdatasource.properties file. Either the username or the encrypted password are not correct in this file.

One way the password could be incorrect is if the password for db2admin was changed using the passwd command instead of changing it through the WebUI.

Resolution

Verify that the line is correct in the /opt/Symantec/simserver/simdbmu/simdatasource.properties file.

db.connection.username=db2admin

If the line is correct, then the db2admin password in the file needs to be reset to its current value. To do this:
SSIM 4.5 

  1. Connect to the SSIM Appliance using a browser with the url https://<SSIM IP>
  2. Click Configure Appliance, then login to the WebUI.
  3. On the left, click Change Password.
  4. Enter "db2admin" for the Username.
  5. Enter the password information.
  6. Click Change Password.

SSIM 4.6 and SSIM 4.7

  1. Connect to the SSIM Appliance using a browser with the url https://<SSIM IP> and login.
  2. At the top, mouse over or click on Settings.
  3. Click Password.
  4. Enter "db2admin" for the Username.
  5. Enter the password information.
  6. Click Change Password.

This process will rewrite the /opt/Symantec/simserver/simdbmu/simdatasource.properties file and restart the simdbmu service.

Note:  If your password contains special characters you will not be able to reset the password via the web interface.
Follow the following steps to resolve the issue:
1) Login to the SSIM via ssh
2) Switch to the root user
su -
3) Enter the following command to change the current db2admin password
passwd db2admin

4) Then go into the web interface, and change the password again using the new alpha/numeric password.
 

The db2admin account password was changed with passwd

If the db2admin accounts password was changed with the passwd command, the above steps will fail because the password confirmation will fail.

Change the password back to the previous password with the passwd command.

Then change the password correctly through the WebUI following the instructions in the previous section.