Getting error after installing the NS Agent and when I try to open the UI for the Altiris Agent on the agent computer
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Article ID: 177239
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Updated On:
Products
IT Management Suite
Issue/Introduction
Getting the following after installing the Symantec Management Agent (NS Agent or Altiris Agent) and when trying to open the UI for the Altiris Agent on the agent computer:
Error activating agent session zero: plug-in not registered: object is not registered(-2147220997).
Environment
ITMS 7.x and later ITMS 8.x and later
Cause
There was previously an agent installed and it was not removed completely.
Resolution
To solve this issue, you'll need to uninstall and reinstall the agent manually. To do this, do the following:
Run the following command line to remove the Altiris Agent using AeXAgentUtil.exe located by default at :\Program Files\Altiris\Altiris Agent\:
AeXAgentUtil.exe /uninstallagents /clean
This will remove all sub-agents and attempt to cleanly remove the Altiris Agent from the system.
Delete the following Program files if still present:
C:\Program Files\Altiris\Altiris Agent
Delete the following registry keys if they are still present:
HKEY_LOCAL_MACHINE | SOFTWARE | Altiris | Altiris Agent HKEY_LOCAL_MACHINE | SOFTWARE | Altiris | eXpress ***DO NOT DELETE THIS key if you are removing the agent from the Notification Server itself. * HKEY_LOCAL_MACHINE | SOFTWARE | Altiris | Scheduler * HKEY_LOCAL_MACHINE | SOFTWARE | Altiris | APackageStub * HKEY_LOCAL_MACHINE | SOFTWARE | Classes | All sub items beginning with Altiris. * HKEY_LOCAL_MACHINE | SOFTWARE | Classes | AppID | {5E038245-CF81-44BE-8018-9A2981B9DC9B}
Search in the Windows directory <WINDIR> using the string below and delete the found files: * AeX*