The aexsvc service has high utilization and is unable to keep up on processing jobs
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The aexsvc service has high utilization and is unable to keep up on processing jobs

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Article ID: 177238

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Updated On:

Products

IT Management Suite

Issue/Introduction

The aexsvc service has high utilization and processing the event queues is slow after implementing Patch Management Solution and Software Delivery Solution.

Cause

The server is being being flooded with Patch Management jobs. They have 10,000 computers and the following settings were listed for Patch Management:
  • Default Windows OS Inventory Policy  Interval = 4 hours
  • Default Windows Software Release Inventory Policy  Interval = 4 hours
  • Default Microsoft Software Inventory Policy  Interval = 4 hours
  • Default Microsoft Vulnerability Analysis Policy  Interval = 4 hours

Resolution

Increase the following settings in Patch Management under:
  • Configuration\Solutions Settings\Software Management\Patch Management\Windows\Software Inventory\Global
  • Configuration\Solutions Settings\Software Management\Patch Management\Windows\Software Inventory\Microsoft

From:

  • Default Windows Software Release Inventory Policy  Interval = 4 hours
  • Default Windows OS Inventory Policy  Interval = 4 hours
  • Default Microsoft Software Inventory Policy  Interval = 4 hours
  • Default Microsoft Vulnerability Analysis Policy  Interval = 4 hours

To:

  • Default Windows Software Release Inventory Policy  Interval = 24 hours
  • Default Windows OS Inventory Policy  Interval = 24 hours
  • Default Microsoft Software Inventory Policy  Interval = 24 hours
  • Default Microsoft Vulnerability Analysis Policy  Interval = 24 hours

Applies To
Notification Server 6.0.5287
10,000+ computers
Patch Management Solution