Symantec Scan Engine: Error event: "The scan engine has been contract error: even severity event: error: scanner: 17"
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Symantec Scan Engine: Error event: "The scan engine has been contract error: even severity event: error: scanner: 17"

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Article ID: 177237

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Updated On:

Products

Scan Engine

Issue/Introduction

You see the error event generated in Windows Event Log saying "The scan engine has been contract error: even severity event: error: scanner: 17". You've noticed that this error occurs while scanning ZIP files created with Winzip and with the "maximum/enhanced deflate" option enabled.

Cause

The problem is related to the way the ZIP file is compressed. At the moment Symantec Decomposer is not able to open those files

Resolution

Symantec is aware of the problem and is working to provide a decomposer fix to address it in one of the next product's maintenance releases.


In the meantime, please follow the workaround below to allow this type of content to be accepted into Symantec Scan Engine:

1. Browse to the product's installation folder on a MS-DOS command prompt and enter the "bin" directory.
2. Download the category3.xml file (below) and copy it manually to the product's install/bin directory.
3. Restart the Scan Engine service
4. Type the following commands:

java -jar xmlmodifier.jar -s //filtering/Container/IgnoreBareLFMalformity/@value true category3.xml
java -jar xmlmodifier.jar -s //filtering/Container/IgnoreBareCRMalformity/@value true category3.xml


5. After the commands are executed, please restart the Scan Engine service.

category3.xml





Attachments

category3.xml get_app