How to uninstall Symantec Mail Security (SMS) Domino when Premium AntiSpam is still enabled and cannot be disabled.
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How to uninstall Symantec Mail Security (SMS) Domino when Premium AntiSpam is still enabled and cannot be disabled.

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Article ID: 177202

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Updated On:

Products

Mail Security for Domino

Issue/Introduction

How to uninstall SMS Domino when Premium AntiSpam is still enabled and cannot be disabled.

Symptoms
Uninstaller fails to uninstall and gives the error that Premium AntiSpam is still enabled and to disable it.


Cause

The uninstaller is not intelligent enough to do the Domino API calls necessary to see if PAS is actually enabled. The way around this was to have the product create the pasenabl file. And because having PAS enabled requires server modifications you need the GUI for disabling PAS so that all the settings go back to the way they were prior to enabling this feature.

Resolution


MANUAL UNINSTALL OF SMSDOM 4.x WITH PAS ENABLED

NOTES: These steps are to be used as a last resort. First try to disable PAS and do a regular uninstall. Uninstalling of SMSDOM 4.x runs in between the MSSMTP service and the Domino SMTP service. To get things back to normal we have to stop the three services and keep them from running which is done in step 3. Then change the port for Lotus Domino SMTP back to 25 which is done in step 11.

WARNING: In step 9 the SMTP server task is shutdown before making the port number change in step 11; this is very important because changing this while the task is running can cause you to the lose your server configuration document.

  1. Make backup of important Lotus configuration files and binaries before continuing on in this process.
  2. Quit Lotus Domino Server. Exit out of any Lotus clients.
  3. Stop the following Windows services and change the Startup type to manual for each:
      • Symantec Premium AntiSpam Conduit
      • Symantec Premium AntiSpam Server
      • Simple Mail Transport Protocol (SMTP)

  4. Change the following registry value from 1 to 0:
      • HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec Mail Security for Domino\Install\PAS\Installed
  5. Remove the following file (Usually this file will not prevent an uninstall):
      • Lotus\Domino\Data\SMSNDB\PAS\pasenabl
  6. Go to Add/Remove programs
  7. Select Symantec Mail Security 4.x for Domino.
  8. Click Uninstall. (It is your choice as to whether or not you want to remove the SAV databases or statistics. It does not make a difference at this time.)
  9. Remove "npas" and "ntask" from "ServerTasks" line in the "notes.ini" file if they exist. Also remove "nnem.dll" from the "EXTMGR_ADDINS" line in the notes.ini (if it is the only "dll" there, you can just delete the whole line).
  10. Start Lotus Domino Server
  11. Go to the Console and type 'TELL SMTP QUIT'
  12. Start Lotus Admin Client
  13. Click the Configuration tab, and then open the server document for the server we are uninstalling from.
  14. Click the Ports> Internet Ports> Mail.
  15. Change the TCP/IP port number for Mail (SMTP Inbound) to 25.
  16. Click Save> Close.
  17. Go to the Lotus Domino Server console type 'LOAD SMTP' (If you are using a newer version of Domino SMTP does not accept TELL commands from steps 11 and 17, you will need to restart the server for the SMTP port change to take affect.)



MANUAL UNINSTALL OF SMSDOM 5.x/7.5 WITH PAS ENABLED

NOTES: These steps are to be used as a last resort. First try to disable PAS and do a regular uninstall. Uninstalling of SMSDOM 5.x does not require checking for whether or not MSSMTP service is running because it is not required. PAS in this version is a Lotus Domino server task which works like an SMTP Proxy between the connecting server and Lotus Domino SMTP server task.

WARNING: In step 7 the SMTP server task is shutdown before making the port number change in step 9; this is very important because changing this while the task is running can cause you to the lose your server configuration document.

  1. You should make backup of important Lotus configuration files and binaries before continuing on in this process.
  2. Quit Lotus Domino Server and Exit out of any Lotus clients.
  3. Delete the following file:
      • Lotus\Domino\Data\SMSNDB\PAS\pasenabl

        Note: (SMSNDB and PAS are hidden folders. Folder options must be changed if you do not already see these folders. Also depending on your settings you may not see the ".dat" extension on the file name)

  4. Change the following registry value from 1 to 0 if it exists:
      • 7.5 HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec Mail Security for Domino\Install\7.5\PAS\Value Installed
      • 5.x HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec Mail Security for Domino\Install\5.1\PAS\Value Installed

  5. Go to Add/Remove programs
  6. Select Symantec Mail Security 5.x for Domino.
  7. Click Uninstall. It is your choice as to whether or not you want to remove the SAV databases or statistics. It does not matter at this time.
  8. Remove "npas" and "ntask" from the "ServerTasks" line in the "notes.ini" file if they exist. Also remove "nnem.dll" from the "EXTMGR_ADDINS" line in the "notes.ini" file (if it is the only dll there you can just delete the whole line.)
  9. Start Lotus Domino Server
  10. Go to the console and type 'TELL SMTP QUIT'. (If you are using a newer version of Domino SMTP then it does not accept TELL commands. This is Ok, continue with the next step.)
  11. Start Lotus Admin Client
  12. Click Configuration
  13. Open the server document for the server we are uninstalling from.
  14. Click Ports> Internet Ports> Mail.
  15. Change the TCP/IP port number for Mail (SMTP Inbound) to 25.
  16. Click Save and Close.
  17. Go to the Lotus Domino Server console and type 'LOAD SMTP'. (If you are using a newer version of Domino SMTP then it does not accept TELL commands from steps 10 and 17, you will need to restart the server for the SMTP port change to take affect.)



References
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Technical Information
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