ServiceDesk install reports "An error has occurred at: AddProfileValueDefinitions"
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ServiceDesk install reports "An error has occurred at: AddProfileValueDefinitions"

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Article ID: 177038

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Updated On:

Products

ServiceDesk

Issue/Introduction

This issue can manifest itself in a number of ways both during the ServiceDesk installation process as well as after the installation (if errors during the installation process are missed or ignored).  We will add new symptoms as we are made aware of them:

 

1) During the ServiceDesk installation the following error appeared:
"An error has occurred at: AddProfileValueDefinitions
Error Message: Server was unable to process request. ---> Exception has been thrown by the target of an invocation. ---> could not save object ProfileServiceDeskSettings ---> Could not insert or update. insert error message: String or binary data would be truncated. The statement has been terminated. update error message: String or binary data would be truncated. The statement has been terminated. ---> String or binary data would be truncated. The statement has been terminated.

Stack Trace: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Exception has been thrown by the target of an invocation. ---> could not save object ProfileServiceDeskSettings ---> Could not insert or update. insert error message: String or binary data would be truncated. The statement has been terminated. update error message: String or binary data would be truncated. The statement has been terminated. ---> String or binary data would be truncated. The statement has been terminated. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at LogicBase.Core.Ensemble.Profile.ProfileService.SaveProfileValueDefinitionsWithInitialValues(String sessionID, ProfileValueDefinition[] profileValueDefinitions, KeyValuePair[] nameValuePairs) at LogicBase.Components.Ensemble.Profile.AddProfileValueDefinitions.Run(IData data) at LogicBase.Core.ExecutionEngine.SinglePathProcessComponentExecutionDelegate.Execute(IData data, IOrchestrationComponent comp, String& outputPath, IExecutionEngine engine, TLExecutionContext context) at LogicBase.Core.ExecutionEngine.AbstractExecutionEngine.DoRunComp(IOrchestrationComponent comp, IData data, TLExecutionContext context)"

The installation process is allowed to continue despite this error,  however the ServiceDesk will not function properly when it is complete.

 

2) When attempting to create a new incident after the ServiceDesk 7.0 install is complete, the following errors appears:
"Value cannot be null. Parameter name: uriString"
OR
"An error has occured.Please try your request later or contact property [ProfileProperties].service_desk_settings_critical_error_contact_name does not exist at property [ProfileProperties].service_desk_settings_critical_error_contact_info does not exist."

 

3) Error appears when you trying to access ServiceDeskSettings: A column named 'ServiceDeskActiveDirectorySyncExchange' already belongs to this DataTable.
Here are the details.
"at System.Data.DataColumnCollection.RegisterColumnName(String name, DataColumn column, DataTable table) at System.Data.DataColumnCollection.BaseAdd(DataColumn column) at System.Data.DataColumnCollection.AddAt(Int32 index, DataColumn column) at System.Data.DataColumnCollection.Add(String columnName) at LogicBase.Ensemble.Profile.DisplayAndEditValues.Page_Init(Object sender, EventArgs e) at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) at System.Web.UI.Control.OnInit(EventArgs e) at System.Web.UI.Page.OnInit(EventArgs e) at System.Web.UI.Control.InitRecursive(Control namingContainer) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)"

Cause

This error is caused by outdated versions of SQL components that must be installed on the ServiceDesk server as prerequisites.  Specificially, one or more of these components may be missing or out-of-date:

SQLServer2005_ADOMD_x64.msi (Microsoft ADOMD.NET)

SQLNCLI_X64.msi (Microsoft SQL Server Native Client)

SQLServer2005_XMO_x64.msi (Microsoft SQL Server 2005 Management Objects Collection)

Resolution

We currently recommend that these files be downloaded from the Feature Pack for Microsoft SQL Server 2005 - December 2008. (http://www.microsoft.com/downloads/details.aspx?FamilyID=536fd7d5-013f-49bc-9fc7-77dede4bb075&displaylang=en)


Applies To

ServiceDesk Solution 7.0