'ItemCacheSize core setting is too small', Agents receive 'malformed http response' errors when attempting to get client policies
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'ItemCacheSize core setting is too small', Agents receive 'malformed http response' errors when attempting to get client policies

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Article ID: 177024

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Updated On:

Products

IT Management Suite

Issue/Introduction

After upgrading to CMS 7.0 and SMS 7.0 SP1, agents began receiving "malformed http response" errors when attempting to get client policies.

In the agent logs the following can be seen:

source="HttpReceiver"
module="AeXNetComms.dll"
process="aexnsagent.exe"
Malformed HTTP response

or Process: aexnsagent.exe (1212)
Thread ID: 1236
Module: AeXNetComms.dll
Source: AeXNetworkTransport
Description: Post to 'http://SERVERNAME/Altiris/NS/Agent/GetClientPolicies.aspx' failed: HTTP error:  (-2147209951)

 

or

Process: aexnsagent.exe (1212)
Thread ID: 1236
Module: aexnsagent.exe
Source: ConfigServer
Description: RequestPolicies failed: HTTP error: (-2147209951)
 

 

 

 

 

 

In the server logs, the following warnings appeared frequently:

Process: w3wp (1296)
Thread ID: 74
Module: w3wp.exe
Source: Altiris.NS.ItemManagement.Item.HandleItemCacheFlooded
Description: ItemCacheSize core setting is too small to satisfy the level of cachable item load requests received. Current Size: 3000

Process: w3wp (9272)
Thread ID: 102
Module: w3wp.exe
Source: Altiris.NS.AgentManagement.PolicyCache.HandleFlooded
Description: Core setting ClientPolicyCacheSize is too small to satisfy incoming requests. Current value: 2000

Cause

Still under investigation.

It appears that the cache size warnings were indicative, though it is unclear whether the cache flooding is the root cause.

Resolution

In several customers' environment, increasing the cache sizes referred to by the warnings, until the warnings were eliminated, also eliminated the 'malformed http response' issue during agent client policy updates.

 

 

To do this:

1) Open  ..Program Files\Altiris\Notification Server\Bin\Tools\NSConfigurator.exe
2) Increase the ItemCacheSize and ClientPolicyCacheMaxSize - Start by doubling the default size. 
            ...By default, the cache sizes are set to 3000 and 2000, respectively.
3) Restart IIS after each increase
4) Monitor the log viewer on the NS - does the warning message re-appear?
     ....If the warning reappears, repeat steps 1-4.

Note:: . Initially you may want to double the default ItemCacheSize and then monitor the situation after the change has taken affect. If necessary keep increasing the cache sizes in smaller increments until you no longer see the ItemCacheSize warnings


Applies To

SMP 7.0 SP2 + HF2

CMS 7.0 SP1

SMS 7.0 SP1