Client Machines are not receiving a GUID after installation of the Altiris Agent.
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Client Machines are not receiving a GUID after installation of the Altiris Agent.

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Article ID: 176952

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Updated On:

Products

IT Management Suite

Issue/Introduction

You have an issue with creating resources with your SMP Server (Symantec Management Platform). The client machines are receiving a GUID from the SMP Server but when it reports back with request configuration or basic inventory there is not a GUID associated.

ERROR CODE/ MESSAGE:

Priority: 4
Tick Count: 19455656
Host Name: ClientMachineName
Process: aexnsagent.exe (1712)
Thread ID: 1692
Module: AeXNetComms.dll
Source: HttpConnection
Description: Direct connection using IP: 192.168.xx.xx, Port: 80

Priority: 4
Tick Count: 19457718
Host Name: ClientMachineName
Process: aexnsagent.exe (1712)
Thread ID: 1692
Module: aexnsagent.exe
Source: ConfigServer
Description: CreateResource.aspx assigned the GUID xxxxxxxx-xxxx-4cf8-b6dc-d96e1db56a10 for this workstation

Priority: 4
Tick Count: 19457734
Host Name: ClientMachineName
Process: aexnsagent.exe (1712)
Thread ID: 1692
Module: AeXNetComms.dll
Source: HttpConnection
Description: Direct connection using IP: 192.168.xx.xx, Port: 80

Priority: 2
Tick Count: 19459734
Host Name: ClientMachineName
Process: aexnsagent.exe (1712)
Thread ID: 1692
Module: aexnsagent.exe
Source: ConfigServer
Description: RequestPolicies failed: Unexpected response from URL http://servername.example.com/Altiris/NS/Agent/GetClientPolicies.aspx: The specified resource does not exist (=) (-2147217405)

Priority: 4
Tick Count: 19459734
Host Name: ClientMachineName
Process: aexnsagent.exe (1712)
Thread ID: 1692
Module: aexnsagent.exe
Source: ConfigServer
Description: Computer not known to server, resetting machine GUID and clearing NSE file queue

Priority: 4
Tick Count: 19459734
Host Name: CND90711JS
Process: aexnsagent.exe (1712)
Thread ID: 1692
Module: aexnsagent.exe
Source: ServerSettings
Description: Next policy request from server servername.domain.com will be at 2024-05-08 13:20:33, in 24 minutes

Environment

ITMS 7.x, 8.x

Cause

In this particular case we found out that under HKLM>Software>Altiris>eXpress>NS, there were some regkeys set to 1 that are needed to process incoming requests:
PauseActivities
PauseNSMessaging
PauseTaskManagers

Resolution

In this particular case when we were waiting to obtain a GUID, we noticed that the NS logs were complaining about the SMP Server was paused. Checked the Altiris Services and those were running. We restarted the Altiris Services service but still displayed that the SMP Server was paused.
We found out that under HKLM>Software>Altiris>eXpress>NS, there were some regkeys set to 1:
PauseActivities
PauseNSMessaging
PauseTaskManagers

After changing those regkeys, we restarted again the Altiris Services.