Symantec Installation Manager has encountered a fatal exception and cannot continue. Please see the log file for more information.
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Symantec Installation Manager has encountered a fatal exception and cannot continue. Please see the log file for more information.

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Article ID: 176947

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Updated On:

Products

IT Management Suite

Issue/Introduction

When Symantec Installation Manager (SIM) starts, the following error occurs:

"Symantec Installation Manager has encountered a fatal exception and cannot continue. Please see the log file for more information"

When you check in the logs, this is the error associated to this fatal exception issue:

Case 1:

Priority: 1
Tick Count: 168350062
Host Name: SMPServer
Process: SymantecInstallationManager (5264)
Thread ID: 7
Module: SymantecInstallationManager.exe
Source: Symantec.Installation.Program.CurrentDomain_UnhandledException
Description: Uncaught Exception in Application

( Exception Details: System.UriFormatException: Invalid URI: The hostname could not be parsed.
   at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
   at System.Uri..ctor(String uriString)
   at Symantec.Installation.EvaluationBrokerProxy.InitializeUserProxyInfo(Service& service)
   at Symantec.Installation.EvaluationBrokerProxy.IsAlive()
   at Symantec.Installation.Context.ProductListingManager.SetProperSimMode()
   at Symantec.Installation.Context.ProductListingManager.LoadProductListing()
   at Symantec.Installation.Context.ProductListingManager.PlLoadAndUpdate()
   at Symantec.Installation.Context.ProductListingManager.<BeginPlLoadAndUpdate>b__0()
   at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart() )
( Exception logged from:
   at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   at Altiris.Diagnostics.Logging.EventLog.ReportException(String strMessage, Exception exception)
   at Symantec.Installation.Program.CurrentDomain_UnhandledException(Object sender, UnhandledExceptionEventArgs e)
   at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
   at System.Uri..ctor(String uriString)
   at Symantec.Installation.EvaluationBrokerProxy.InitializeUserProxyInfo(Service& service)
   at Symantec.Installation.EvaluationBrokerProxy.IsAlive()
   at Symantec.Installation.Context.ProductListingManager.SetProperSimMode()
   at Symantec.Installation.Context.ProductListingManager.LoadProductListing()
   at Symantec.Installation.Context.ProductListingManager.PlLoadAndUpdate()
   at Symantec.Installation.Context.ProductListingManager.<BeginPlLoadAndUpdate>b__0()
   at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
 )
( Extra Details:  Type=System.UriFormatException Src=System )

Case 2:
In some cases you may see this error message as well:

Priority: 1
Tick Count: 596640640
Host Name: NSServer
Process: SymantecInstallationManager (8168)
Thread ID: 7
Module: SymantecInstallationManager.exe
Source: Symantec.Installation.SimApplication.CurrentDomain_UnhandledException
Description: Uncaught Exception in Application

( Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.
   at Symantec.Installation.Context.ProductListingManager.LoadProductListing()
   at Symantec.Installation.Context.ProductListingManager.PlLoadAndUpdate()
   at Symantec.Installation.Context.ProductListingManager.<BeginPlLoadAndUpdate>b__0()
   at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart() )
( Exception logged from:
   at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   at Altiris.Diagnostics.Logging.EventLog.ReportException(String strMessage, Exception exception)
   at Symantec.Installation.SimApplication.CurrentDomain_UnhandledException(Object sender, UnhandledExceptionEventArgs e)
   at Symantec.Installation.Context.ProductListingManager.LoadProductListing()
   at Symantec.Installation.Context.ProductListingManager.PlLoadAndUpdate()
   at Symantec.Installation.Context.ProductListingManager.<BeginPlLoadAndUpdate>b__0()
   at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
 )
( Extra Details:  Type=System.NullReferenceException Src=SymantecInstallationManager )

Environment

ITMS 8.x

Cause

Case 1:
Unknown. For some reason the Proxy settings have the wrong values. In this particular case, the issue was that the User Profile created by SIM for the installation process had two registry keys that were set improperly. There is an Autodetect setting for proxy and one for manually adding the proxy information. By design, if the regkey for autodetect is set to 1, it will ignore the proxy servername for the servername regkey and the port regkey as well. If the Autodetect regkey is set to 0, then it will check what value the servername and port regkeys have. For this instance, Autodetect was set to 0 but also the Servername was empty. This caused a fatal exception in the code. However, the actual Settings interface for SIM doesn't allow to save the proxy settings if Autodetect is uncheck and there is not a proxy server name added. We are not sure how those regkeys were modified in that pattern that caused the fatal exception.

Case 2:
In this specific instance, the issue was caused because one of the product listings entries in the registry was deleted or corrupted. SIM keeps track of what was the last product listing set to be used. The regkey that shows what product listing is in use is called 'Current' under 'HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings'

Resolution

Case 1:
Check the following registry keys:

1. Under HKLM>Software>Altiris>AIM>Configuration>Users>[current logged user account]>Proxy, check that Autodetect is not set to 0 and Servername is empty. If that is the case, change Autodetect regkey to 1 or add the servername and port for your proxy server.

This is the expected setup:

[HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\Users\altirisadmin@Altiris\Proxy]
"AutoDetect"=dword:00000001
"ServerName"=""
"Port"=dword:00000050

or

[HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\Users\altirisadmin@Altiris\Proxy]
"AutoDetect"=dword:00000000
"ServerName"="Myproxyservernamegoeshere"
"Port"=dword:00000050

If you have this:

[HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\Users\altirisadmin@Altiris\Proxy]
"AutoDetect"=dword:00000000
"ServerName"=""
"Port"=dword:00000050

It will cause the fatal exception mentioned for this KB article.

2. If you can't check the regkeys mentioned in the previous step, then log out and log in as a different user and open SIM. It should have the default settings for the Proxy and the error should not occur.

Case 2:
In this particular case check the regkey called 'Current' under 'HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings' and see what value is set to. If it is set to 1 for example and under 'HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings' you see only a key with '0', then it is pointing to a non-existing reference for a product listing set to 1. Change the 'Current' regkey to '0' (which is the default product listing) or any other product listing that exists under 'HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings'.