Getting "Logon failure: the user has not been granted the requested logon type at this computer" when trying to start the Altiris Services.
search cancel

Getting "Logon failure: the user has not been granted the requested logon type at this computer" when trying to start the Altiris Services.

book

Article ID: 176945

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

Unable to start the Altiris Services on his Server.

Checked the Event logs and under the "Application" log the following error was noticed:

"The AeXSvc service was unable to log on as EXAMPLE\altirisadmin with the currently configured password due to the following error:
Logon failure: the user has not been granted the requested logon type at this computer."
 
Service: AeXSvc
Domain and account: Domain\altirisadmin

 
This service account does not have the necessary user right "Log on as a service."
 
User Action
 
Assign "Log on as a service" to the service account on this computer. You can use Local Security Settings (Secpol.msc) to do this. If this computer is a node in a cluster, check that this user right is assigned to the Cluster service account on all nodes in the cluster.
 
If you have already assigned this user right to the service account, and the user right appears to be removed, a Group Policy object associated with this node might be removing the right. Check with your domain administrator to find out if this is happening.
For more information, see Help and Support Center at https://support.microsoft.com/en-us.

Environment

ITMS 8.x

Cause

The exact cause of this issue is unknown but there may have been a GPO that was affecting the credentials for the Notification Server AppID account.

Resolution

1. Change the Log On account from the AppID to Local system Account for the Altiris Service service.
2. Restart the Altiris Service service. It should start the service without problems.
3. Put back the AppID account again for the Log On account.
4. Restart the Altiris Service service again. It should start without problems.
5. Restart the remaining Altiris services using the AppID without changing the Log On account to Local System.