Computers booting to WinPE with DAgent are not "showing up" in the console. Engine logs show Invalid-Primary-Lookup-Key
search cancel

Computers booting to WinPE with DAgent are not "showing up" in the console. Engine logs show Invalid-Primary-Lookup-Key

book

Article ID: 176934

calendar_today

Updated On:

Products

Deployment Solution

Issue/Introduction

When we boot a machine into WinPE 2.1 PXE Automation, it loads the DAgent and reports "Client Record updated" but the machine does not show up in the Deployment Server console.

 

A look at the engine logs shows the following:

Reply=UpdateComputer
Staus=Invalid-Primary-Lookup-Key
Result=Failure

 

 

We also noted that there was no Serial Number, MAC address or anything related to a primary lookup key.

Cause

In at least one case, the cause was a lack of the WinPE WMI code.  DAgent makes WMI calls to determine the Serial Number and such.  If, in order to save space, you remove those default options from WinPE, DAgent will not be able to perform it's tasks.

Resolution

Re-check the two "optional components" for WinPE involving WMI and scripting, and then rebuild the WinPE configuration to resolve the issue.


Applies To

DS 6.9, DAgent, WinPE 2.1

Attachments