Cannot generate SSPI context error after changing SQL service accounts
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Cannot generate SSPI context error after changing SQL service accounts

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Article ID: 176922

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Updated On:

Products

IT Management Suite

Issue/Introduction

After changing the SQL service accounts the Notification Server gives the following error

Process: aexsvc.exe (244)
Thread ID: 540
Module: AltirisNativeHelper.dll
Source: Altiris.NS.Scheduling.ScheduleService.ProcessSchedule
Description: Additional info 'Package Distribution Point Update Schedule'. Exception: Failed to open database connection. Current user is HQ\Altiris. Error: Cannot generate SSPI context.    at Altiris.NS.Utilities.DbUtils.OpenConnection(SqlConnection dbConn)
   at Altiris.NS.Utilities.DbUtils.CreateConnection(String configKey)
   at Altiris.NS.Utilities.DbUtils.CreateConnection()
   at Altiris.NS.ContextManagement.DatabaseContext..ctor(ContextIdentity identity, Boolean beginTransaction, IsolationLevel isolationLevel)

Cause

SQl server required the SPN to be re-registered

Resolution

Follow the instructions in the following article 

http://support.microsoft.com/kb/811889

Applies To
NS 6 Sp3