Getting "Exception encountered while verifying webservice: System.Net.WebException: The operation has timed out" warnings during Symantec Installation Manager installation process.
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Getting "Exception encountered while verifying webservice: System.Net.WebException: The operation has timed out" warnings during Symantec Installation Manager installation process.

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Article ID: 176915

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Updated On:

Products

IT Management Suite

Issue/Introduction

During the installation of CMS, SMS, or Symantec Management Platform (NS), SIM fails to install displaying the following warnings in the SIM Installation Logs:

Priority: 4
Date: 4/27/2009 8:05:08 AM
Tick Count: 2806921
Host Name: ServerName
Process: SymantecInstallationManager (2556)
Thread ID: 37
Module: SymantecInstallationManager.exe
Source: Symantec.Installation.ConfigureNS.EnsureIISServiceIsRunning
Description: IIS service running.

**************************************
Priority: 4
Date: 4/27/2009 8:05:08 AM
Tick Count: 2806921
Host Name: ServerName
Process: SymantecInstallationManager (2556)
Thread ID: 37
Module: SymantecInstallationManager.exe
Source: Symantec.Installation.WebServiceFactory.Create
Description: Initializing WebService (NSConfigurationWebServiceProxy) at Url: http://Servername.example.com/Altiris/NS/Services/NSConfigurationWebService.asmx

****************************************
Priority: 4
Date: 4/27/2009 8:05:08 AM
Tick Count: 2806921
Host Name: ServerName
Process: SymantecInstallationManager (2556)
Thread ID: 37
Module: SymantecInstallationManager.exe
Source: Symantec.Installation.WebServiceFactory.ServiceAvailable
Description: Verifying webservice is available at Url: http://Servername.example.com/Altiris/NS/Services/NSConfigurationWebService.asmx

****************************************
Priority: 2
Date: 4/27/2009 8:05:08 AM
Tick Count: 2906937
Host Name: ServerName
Process: SymantecInstallationManager (2556)
Thread ID: 37
Module: SymantecInstallationManager.exe
Source: Symantec.Installation.WebServiceFactory.ServiceAvailable
Description: Exception encountered while verifying webservice: System.Net.WebException: The operation has timed out
   at System.Net.HttpWebRequest.GetResponse()
   at Symantec.Installation.WebServiceFactory.ServiceAvailable(Type t, String webServiceRootUrl)

******************************************
Priority: 2
Date: 4/27/2009 8:05:08 AM
Tick Count: 2906937
Host Name: ServerName
Process: SymantecInstallationManager (2556)
Thread ID: 37
Module: SymantecInstallationManager.exe
Source: Symantec.Installation.Context.WizardProcess.InstallManager.configNS_ConfigureFailedEvent
Description: Configuration failure occurred.  Dequeuing any additional queued install sessions.


The installation seems to hang and later on, it fails.

Environment

ITMS 7.x, 8.x

Cause

Unknown. Apparently, IIS is not able to restart some of the Web Services called by the installation process.

Resolution

So far restarting IIS and then retrying to install should work. In some other cases, rebooting the server and restarting the installation process should work as well.