PMImport fails to download due to NS 'Unable to connect to remote server' error.
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PMImport fails to download due to NS 'Unable to connect to remote server' error.

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Article ID: 176905

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

PMImport fails to download due to NS 'Unable to connect to remote server' error.

 

 

Excerpt from the Altiris Logs:
Source: Altiris.PatchManagementCore.Utilities.Web.DoDownloadHttpWithBasicAuthentication

Description: Download failed for 'http://www.solutionsam.com/imports/7_0/patch/microsoft/pmimport.cab'. Unable to connect to the remote server

 

Found one incident that threw the following error when staging bulletins: '403 Forbidden'

Cause

Proxy configuration causing problems with download. Able to connect with IE to the 'http://www.solutionsam.com/imports/7_0/patch/microsoft/pmimport.cab' to access the .cab files, but the error resides when attempted through NS/PM. (Firewall settings may also contribute to this issue)

Resolution

 

Verify that the proxy settings are set properly and test the settings. If they work and you are still unable to download the latest PMImport, check the Enable keep alive switch.
This is configured on Console > Settings > All Settings > Notification Server > Notification Server Settings, and in the right pane, select the Proxy Tab.

 


Note: PMImport runs through the Anonymous User rights. Be sure to allow for that user to have permissions to access the .cab file through the Proxy settings. Inputting the Admin Credentials into this location forces the PMImport to run through the specified rights. (In one instance; input the credentials and restarted NS to reset services, and waited for permissions to sync up, and that worked for one environment).

 

Applies To

 

Notification Server 7.0

Patch Management 7.0

Attachments