Software Portal Agent Install defaulting to Logged-on User - Fails to install with inadequate rights
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Software Portal Agent Install defaulting to Logged-on User - Fails to install with inadequate rights

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Article ID: 176872

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Updated On:

Products

Software Management Solution

Issue/Introduction

Software Portal Agent Install defaulting to Logged-on User, By default it uses the logged-in User’s credentials.  The execution fails with insufficient rights errors.

Cause

Many environments, 80% probably, do not give install rights to their users, so the Software Portal Agent installation is failing due to insufficient rights.

Resolution

This is a known issue that will be fixed in a later version of Software Management Solution.  However there is an easy way to work around the issue. 

You can modify the rollout of the Software Management Solution Agent to include the Software Portal.  Follow these steps to accomplish this:

  1. In the Symantec Management Console browse under Settings > All Settings > Agents/Plug-ins > Software > Software Management > Windows > and select the Software management Solution Agent for Windows - Install.
  2. Under the Program name dropdown choose install with Software Portal - No UI.
  3. Click the Save changes button.
  4. Now this policy will also install the Portal.

Alternately, you can follow the steps below to create a Quick Delivery Task that will install the Software Portal Agent with the Software Management Agent.

  1. In the Symantec Management Console browse under Manage > Jobs and Tasks > System Jobs and Tasks > Software > Quick Delivery.
  2. Right-click on the Quick Delivery folder and choose New > Job or Task.
  3. In the left-hand tree look under Software > and select Quick Delivery.
  4. Name the Task from Quick Delivery to "Software Management Agent with the Software Portal".
  5. In the Software resource field type Software Management.
  6. Click the dropdown arrow and choose Software Management Solution Agent 7.0.1287.0 - English (United States).
  7. Within the Command line dropdown choose Intall with Software Portal - No UI.
  8. Click Advanced.
  9. Click on the Run Options tab.
  10. Change the Run As option to Altiris Agent credential (typically the System Account) and click OK.
  11. Click OK to save the Task.
  12. Use the scheduler option on the right-hand pane to roll this out.

If you notice, both option require a launch of the Software Management Solution Agent Install.


Applies To
Symantec Management Platform 7.0
Software Management Solution 7.0