Client showing error " PXE-E74 No MAN_INFO" or "OS_INFO options found" when attempting to PXE boot
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Client showing error " PXE-E74 No MAN_INFO" or "OS_INFO options found" when attempting to PXE boot

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Article ID: 176858

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Updated On:

Products

Deployment Solution

Issue/Introduction

We have a PXE server that will not successfully pass down the bootstrap (Bstrap.0) file to our clients.  When clients PXE boot, they get either error "PXE-E74 No MAN_INFO or OS_INFO options found" or "PXE-M0F: Exiting Intel Boot Agent".

Cause

Initially this appeared to be caused by using PXE in forced mode.  The Wireshark trace showed a very long string of hexadecimal code for the Vendor Device ID.  Much longer than as it appeared in the PXE Force Mode Utility.  It was also noted that the PXE Server was trying to send down the x64 bootstrap despite these not being x64 machines.  Both of these behaviors were side affects of the root cause which was that a Cisco router had DHCP filtering turned on.  This was affecting the PXE boot even though the PXE Server and client were on the same network segment.  The switch for that LAN segment also had Bootp forwarding disabled.

Resolution

The router needed to have DHCP filtering turned off and the switch has to allow Bootp forwarding.

Review DHCP Scope Options as if previously PXE was configured in Forced Mode - configuration might be pointing to old IP. You can use PXE Forced Mode Utility from KB 28035. (Linked Article).

Another case that showed this issue was resolved by uninstalling the PXE server completely (leaving only the mmaccesskey.ini file in the PXE directory), reinstalling the PXE server and creating new PXE boot images.


Applies To
Deployment Solution 6.9 SP1 (MP1 added also)

Using PXE Forced Mode