Altiris agent service will not start. Access denied errors in agent.log
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Altiris agent service will not start. Access denied errors in agent.log

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Article ID: 176835

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Updated On:

Products

IT Management Suite

Issue/Introduction

Security in a domain has changed, now the "Altiris Agent Service" on the Workstation will not start.  In the agent.log you will see errors similar to the following:

 

<event date='Nov 07 07:22:40' severity='1' hostName='WORKSTATION1' source='AeXAgentActivate' module='AeXAgentActivate.exe' process='AeXAgentActivate.exe' pid='3276' thread='3292' tickCount='216484' >
  <![CDATA[Error activating agent session 0: Access is denied. (-2147024891)]]>
</event>
<event date='Nov 07 07:22:41' severity='1' hostName='WORKSTATION1' source='ComService' module='AeXNSAgent.exe' process='AeXNSAgent.exe' pid='3364' thread='3460' tickCount='216890' >
  <![CDATA[Unexpected error in ServiceMain: Failed to register class objects: The class is configured to run as a security id different from the caller (-2147467243)]]>
</event>

Cause

Security in one of the domains changed. Now Workstations are not able to start the Altiris Agent Services.

Resolution

On the workstation throwing these errors, run the following command: 

"C:\Program Files\Altiris\Altiris Agent\AeXAgentUtil.exe" /registerclient

This should register the .dll's needed for the agent to start.  You can also push this command out using Deployment Server or Login Script. It may also be possible to get Task Server to run this command if the Task Client is started, but as a precaution to you, this has not been tested by support and may not work.


Applies To
NS 6.0 with more than one domain.