Error "File could not be opened" appears when running a Modify Configuration task with Linux Automation
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Error "File could not be opened" appears when running a Modify Configuration task with Linux Automation

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Article ID: 176818

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Updated On:

Products

Deployment Solution

Issue/Introduction

The error appears when modify configuration is executed:

FIRM status 41, file could not be opened.

And the firm.log:

Error description:

The file could not be opened.

Possible causes:
     A file that was expected to exist does not exist.

     You do not have permission for this operation on the file or directory.

Possible resolutions:

     Make sure the file exists and is accessible.

     If the missing file is part of this program, reinstall the program.

     Fix the permissions on the file or directory
==================== Technical details ====================
Logfile = created Tue Jul 29 09:34:20 2008

  Build = firm 6.9 (8853)

Cmdline = /mnt/ds/RDeploy/Linux/firm copy .Tempc5000677.cfg prod:aclient.cfg
Status = 41 (0x29)

Source file = imglib/fs/native/nativefs.cpp

Line number = 806 (0x326)

Stack trace = 0x80b525d 0x80b5559 0x804f6dd 0x8053a63 0x804b3cd&Known=0x811d080
Path = .Tempc5000677.cfg
Imaging library revision = 8853 (linux-x86-release build, Fri Feb 22 18:36:45 2008)

Cause

Missing the forward slash (/) symbol in the the syntax for command line in Linux PE.

Resolution

Symantec Support is aware of this issue. This syntax error will be fixed in upcoming release of Deployment Solution 6.9 SP1. To work around this issue, use other PE (such as DOS or WinPE) than Linux for Modify Configuration tasks.

Applies To

Deployment Solution 6.9
Using Linux PE for Modify Configuration task.