Getting error "Notification Server Error. An error has occurred that is preventing the console from displaying correctly." when opening 'First Time Setup' page under Settings>All Settings>Notification Server.
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Getting error "Notification Server Error. An error has occurred that is preventing the console from displaying correctly." when opening 'First Time Setup' page under Settings>All Settings>Notification Server.

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Article ID: 176809

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Updated On:

Products

IT Management Suite

Issue/Introduction

When opening the page 'First Time Setup' under Settings>All Settings>Notification Server, the following message appears:

Notification Server Error

An error has occurred that is preventing the console from displaying correctly.

If this is being shown in place of a page in the Symantec Management Console, navigate back to the page using the menu or tree and continue working. If the problem persists, see your local network administrator.

If this is being shown in place of the Symantec Management Console, one of the following could be the cause:

  • The "Altiris Service" service is not running. Start this service on the Notification Server computer and reload the console.
  • "Microsoft Internet Information Services" is not running. Start this service on the Notification Server computer and reload the console.
  • The account used for either the "Altiris Service" or the Notification Server webs is incorrect, disabled or the password for the account has expired. On the Notification Server computer, run "C:\Program Files\Altiris\Notification Server\bin\AeXConfig.exe /svcid user:(user name) password:(password)]", substituting the correct installation path if a non-default location was used, to provide a new account.

In both cases, the Notification Server log may contain useful information. It can be accessed on the Notification Server computer by running "Start" menu > "All Programs" > "Altiris" > "Diagnostics" > "Altiris Log Viewer".

The following error is noticed in the NS logs:

Priority: 1
Date: 9/15/2008 1:33:00 PM
Tick Count: 185843953
Host Name: NS7SERVER
Process: w3wp (4980)
Thread ID: 64
Module: w3wp.exe
Source: global.asax
Description: Unhandled exception.  Type=System.ArgumentException Msg=An entry with the same key already exists.
StackTrace=
   at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
   at System.Collections.Generic.SortedList`2.Add(TKey key, TValue value)
   at Altiris.CustomConsole.Web.FirstTimeSetup.QuickStartSteps.Page_Load(Object sender, EventArgs e)
   at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
   at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
   at System.Web.UI.Control.OnLoad(EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Cause

Unknown. Bad code in the Beta files.

Resolution

The issue was duplicated using NS 7.0.3798. However, the issue is not longer present on NS 7.0.3876

Applies To
Notification Server  7.0.3798
Symantec Installation Manager 7.0.321