Error, "CTaskAgentBase::CheckRegister(): Not registered, attempting to register now"
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Error, "CTaskAgentBase::CheckRegister(): Not registered, attempting to register now"

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Article ID: 176808

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Updated On:

Products

IT Management Suite Task Server

Issue/Introduction

Client Task Agents are not able to register with their Task Server. The CTA records the following information entry in the agent.log file:

CTaskAgentBase::CheckRegister(): Not registered, attempting to register now.

When verbose logging was enabled, it recorded the following entries:

CTaskServerConnection::Register(): CAtrsException exception, error = "Unable to resolve host name FQDN", OS error = 11004, at line 71  re-throw at CAtrsIPInfo::ResolveAddress  re-throw at CAtrsIPInfo::ConvertAddress  re-throw at CAtrsSocketIPAddress::CAtrsSocketIPAddress(lpsz)  re-throw at CAtrsHttpConnection::ProxyConnect  re-throw at CAtrsHttpConnection::Connect  re-throw at CAtrsHttpRequest::Connect  re-throw at CAtrsHttpRequest::BeginSendRequest  re-throw at CAtrsHttpRequest::SendRequest  re-throw at CAtrsAutoAuthenticateHttpRequest::SendRequest  re-throw at CClientTaskServerConn::UpdateCoordinationServerList  re-throw at CClientTaskServerConn::Register

CTaskServerConnection::GetTaskInstances(): CAtrsException exception, error = "The URL /GetTasks.aspx?resourceGuid=fc9f36a8-8dd7-4f4c-a1af-f088d53ba1c4 is in an unknown format", OS error = 2147549183, at line 73  re-throw at CAtrsHttpHeader::ParseUrl  re-throw at CAtrsHttpHeader::CreateRequest  re-throw at CAtrsHttpRequest::Create  re-throw at CClientTaskServerConn::TryGetTasks  re-throw at CClientTaskServerConn::GetTasks

CTaskAgentBase::OnUpdateTasks(): CAtrsException exception, error = "Unable to update active task list", OS error = 2147549183, at line 230

CTaskServerConnection::Register(): CAtrsException exception, error = "Unable to connect to 14676D9C, port 8000", OS error = 10060, at line 149  re-throw at CAtrsBSDSocket::Connect(sockaddr_in)  re-throw at CAtrsBSDSocket::Connect(CAtrsSocketAddress)  re-throw at CAtrsHttpConnection::ProxyConnect  re-throw at CAtrsHttpConnection::Connect  re-throw at CAtrsHttpRequest::Connect  re-throw at CAtrsHttpRequest::BeginSendRequest  re-throw at CAtrsHttpRequest::SendRequest  re-throw at CAtrsAutoAuthenticateHttpRequest::SendRequest  re-throw at CClientTaskServerConn::UpdateCoordinationServerList  re-throw at CClientTaskServerConn::Register

CTaskServerConnection::Register(): CAtrsException exception, error = "Unable to connect to 96BBBF9D, port 8000", OS error = 10060, at line 149  re-throw at CAtrsBSDSocket::Connect(sockaddr_in)  re-throw at CAtrsBSDSocket::Connect(CAtrsSocketAddress)  re-throw at CAtrsHttpConnection::ProxyConnect  re-throw at CAtrsHttpConnection::Connect  re-throw at CAtrsHttpRequest::Connect  re-throw at CAtrsHttpRequest::BeginSendRequest  re-throw at CAtrsHttpRequest::SendRequest  re-throw at CAtrsAutoAuthenticateHttpRequest::SendRequest  re-throw at CClientTaskServerConn::UpdateCoordinationServerList  re-throw at CClientTaskServerConn::Register

Cause

Although there were no "Unable to register" log entries, Internet Explorer and Notification Server Agent proxy settings were looked at.

Internet Explorer is configured to auto-detect the proxy settings. The Notification Server Agent proxy settings were as follows (HKLM\Software\Altiris\Communications):

  1. “Proxy Auto Detect” DWORD 1
  2. “Proxy Last Resort” DWORD 1
  3. “Proxy Server” REG_SZ value of that mentioned in the unable to connect/resolve log entries.
  4. “Proxy Port” DWORD value of 8000

Resolution

Remove the value from the “Proxy Server” REG_SZ and change the value of the “Proxy Port” DWORD to 0. The Client Task Agent will be able to register with its Task Server after the Notification Server Agent service was restarted.

Applies To
Notification Server 6.0.6074 R7 with Task Server 6.0 SP1