Getting HTTP Error 500 when trying to open the Error Logging page in the Altiris Console
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Getting HTTP Error 500 when trying to open the Error Logging page in the Altiris Console

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Article ID: 176796

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Updated On:

Products

IT Management Suite

Issue/Introduction

I am getting HTTP Error 500 when accessing the logview.asp page (or any other ASP page).

When I try to open any ASP page from the Altiris Console, after the "friendly HTTP errors" (in Internet Explorer under Tools > Internet Options > Advanced > Show Friendly HTTP error messages) option is turned off, I see "The request resource is in use."

As well, when checking the IIS logs, any request to postevent.asp page is getting the HTTP Error 500 as well.

Cause

ASP pages were disabled. Possible GPO settings disabled some of the main components for ASP pages to load.

Resolution

The following could be suggested as a solution:
  1. Check the VBScript component of ASP and re-register the ASP.NET runtime to IIS for this issue.
    1. Re-register .NET 1.1 on your Notification Server. See article 27432, "What are the most common commands for registering .NET 1.1.4322?"
    2. Go to the folder [system driver:]\\Inetpub\AdminScripts\ in one command window and type the command:
      cscript synciwam.vbs /v

      Note: The VBscript component is the render engine of ASP on processing the VBscript code. If it runs into error, ASP extension will not successfully load it which will produce an error.

      If this command failed (send me an screenshot of what the command above returned), this means the VBScript engine is corrupted, then we could type the command below to re-register it. See steps 2-3 below.
      If there are not errors but still not able to load an ASP page, then try steps 2-3.
  2. From the RUN prompt, try regsvr32 %windir%/system32/vbscript.dll.
  3. From the RUN prompt, try regsvr32 %windir%/system32/jscript.dll.

If the above suggestion didn't work:

  1. Verify from IIS Manager under Default Web Site, right-click Properties and choose Home Directory tab > Configuration button the 'Cache ISAPI extensions' check box is actually checked.
  2. As well, under that the Application Extensions list, .asp extension is listed. You may need to re-register the asp.dll as a possible fix (regsvr32 %windir%/system32/inetsrv/asp.dll).

Another suggestion could be to make sure that all the updates available for Windows, IIS and ASP are installed.


Applies To
Notification Server 6.0.6074 SP3  R8
SQL Server 2000
Windows Server 2003