Unable to access the Altiris Console with error "SQL Server or Catalog are not set in CoreSettings.Config"
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Unable to access the Altiris Console with error "SQL Server or Catalog are not set in CoreSettings.Config"

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Article ID: 176789

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Updated On:

Products

IT Management Suite

Issue/Introduction

You are not able to open the SMP Console. You get the following message in the browser:

Server Error in '/Altiris/Console' Application.
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SQL Server or Catalog are not set in CoreSettings.Config
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: Altiris.NS.Exceptions.DatabaseNotReadyException: SQL Server or Catalog are not set in CoreSettings.Config

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. 

Stack Trace:
[DatabaseNotReadyException: SQL Server or Catalog are not set in CoreSettings.Config]
   Altiris.NS.Utilities.DbUtils.CreateConnection(String configKey)
   Altiris.NS.ContextManagement.DatabaseContext..ctor(ContextIdentity identity, Boolean beginTransaction, IsolationLevel isolationLevel)

[DatabaseNotReadyException: Failed to construct DatabaseContext object. Connection to database failed.]
   Altiris.NS.ContextManagement.DatabaseContext..ctor(ContextIdentity identity, Boolean beginTransaction, IsolationLevel isolationLevel)
   Altiris.NS.ContextManagement.DatabaseContext.GetContext(Boolean createNewTransaction, IsolationLevel isolationLevel, ContextIdentity identity, Boolean independentContext)
   Altiris.NS.ContextManagement.DatabaseContext.GetContext()
   Altiris.NS.UI.AltirisPage.OnInit(EventArgs e)
   Altiris.CustomConsole.Web.Header.OnInit(EventArgs e) +23
   System.Web.UI.Control.InitRecursive(Control namingContainer) +241
   System.Web.UI.Page.ProcessRequestMain() +197

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Environment

ITMS 7.x, 8.x

Cause

Possible corruption of coreSettings.config since the SQL Server name was missing on the config file.

Resolution

As the error message specifies, for some reason the coreSettings.config is missing either the SQL Server or Catalog value name.

  1. Open the coreSettings.config file (under ...\ProgramData\Symantec\SMP\Settings)
  2. Look for the following lines:

    <customSetting key="DbServer" type="local" value="" />
    <customSetting key="DbCatalog" type="local" value="" />

  3. Check if the "value" parameter is missing the SQL Server name or the name of the database. If it is, then add it and save the file.
  4. Reopen the Altiris Console (make sure that you try to access the Altiris Console using the AppID account so you can avoid "Access Denied" messages).