The Altiris Agent is using most of the computer's CPU. This happens on only a small percentage of computers in the network that are running the Altiris Agent.
Cause
If a Task XML file becomes bad or corrupt, the NS Agent cannot parse it correctly, so it tries to regenerate it. This causes many more XML files to be created in the C:\Program Files\Altiris\Altiris Agent\Tasks folder. The Altiris Agent is constantly processing the tasks but isn't able to keep up with the new XML tasks that are being created.
Resolution
If the C:\Program Files\Altiris\Altiris Agent\Tasks directory on the computer running the Altiris Agent contains a lot of XML files instead of only a few (usually 3 or 4), do the following:
On the client computer, stop the Altiris Agent service. Right-click My Computer, then click Manage. When the Computer Managment window appears, click Services and Applications, then click Services. Right-click Altiris Agent and click Stop.
Delete all XML files from the C:\Program Files\Altiris\Altiris Agent\Tasks directory.
Start the Altiris Agent service. Right-click My Computer, then click Manage. When the Computer Managment window appears, click Services and Applications, then click Services. Right-click Altiris Agent and click Start.
Optional: Manually update the client computer's configuration:
Right-click the Altiris Icon in the system tray and clicking Altiris Agent Detals. When the "About Altirs Agent" window appears, click the Update Configuration button.
If you don't manually update the computer's configuration, it will update at the next schedule time.