Error sending message when configuring email settings in Notification Server
search cancel

Error sending message when configuring email settings in Notification Server

book

Article ID: 176779

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

Email configuration page in Notification Server displays an error when attempting to send a test message: "There was an error sending your message. Make sure you have specified a valid SMTP server." This occurs despite the correct configuration of the email settings within NS.

Server a.logs may contain the following critical error:

Altiris.NS.Utilities.MailStdScripting.SendSMTPSync     (Unhandled exception.  Type=Quiksoft.EasyMail.SMTP.SMTPConnectionException Msg=Error connecting to server. <hostname.domain> Src=SMTP.Net
StackTrace=
   at Quiksoft.EasyMail.SMTP.SMTP.Connect(String Domain)
   at Quiksoft.EasyMail.SMTP.SMTP.a(String A_0, l A_1, ai A_2)
   at Quiksoft.EasyMail.SMTP.SMTP.a(String A_0, EmailMessage A_1, ai A_2)
   at Quiksoft.EasyMail.SMTP.SMTP.Send(EmailMessage MessageObj)
   at Altiris.NS.Utilities.MailStdScripting.SendSMTPSync(MailMessage mailMsg) )

Cause

Since the SMTP email subsystem was changed in Notification Serer 6.0 SP2 the Altiris Service is emitting the email directly (instead of using DCOM as previously done).

McAfee EPO blocks access to port 25 for the aexsvc.exe, thus causing the error.

Resolution

Exclude aexsvc.exe from the McAfee block rules allowing NS to access port 25 and send email via SMTP.

Applies To

Any version of Notificaton Server (6.0/7.0)