Getting error "Failed to get the list of available databases, check your database credentials" when trying to connect to SQL Server 2005 during NSSetup
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Getting error "Failed to get the list of available databases, check your database credentials" when trying to connect to SQL Server 2005 during NSSetup

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Article ID: 176735

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Updated On:

Products

IT Management Suite

Issue/Introduction

When running NSSetup (http://localhost/Altiris/NS/Install/NSSetup.aspx) the following error message appears:

Failed to get the list of available databases, check your database credentials.



In this case customer is trying to use a Remote SQL Server 2005 or SQL Server 2005 Express (Case 1).

Sometimes you may also get the same error when your SQL Server 2005 is local to the Notification Server (Case 2).

As well, when you access the Microsoft SQL Server Management Studio from the actual SQL Server, you are able to access the available databases without problems. However, when trying to access the Microsoft SQL Server Management Studio from a remote machine, in this case the Notification Server, you may see an error message like this one:

Cannot connect to SQLServer\Instance
Additional information:
A connection was successfully established with the server, but then an error occurred during the pre-login handshake. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (Provider: Named Pipes Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

Cause

The SQL Server client cannot connect to the server. This error could occur because the server is not configured to accept remote connections.

See as well  http://www.microsoft.com/products/ee/transform.aspx?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=233

Resolution

Case 1

If the issue occurs when trying to connect to a Remote SQL Server 2005, try the following steps:

  1. Go to Start > All Programs > Microsoft SQL Server 2005 > Configuration Tools > SQL Server Configuration Manager.
  2. Under SQL Server 2005 Network Configuration, make sure that TCP/IP or Named Pipes are listed as 'Enabled' (in order to enable them, right-click and choose Enable). If you had to enable them, you will need to restart the SQL Server service in order to take effect.
  3. Under SQL Native Client Configuration, make sure that TCP/IP or Named Pipes are listed as "Enabled" as well.
  4. Try to open the Notification Server Console (if you had Notification Server already running previously). Otherwise, run NSSetup one more time.

Case 2

If the issue occurs when trying to connect a local SQL Server 2005 using localhost as server name, please try the following (from the Notification Server 6.0 SP3 Release Notes):

6.1.9 Install Wizard failing to automatically detect locally installed SQL Server 2005

The Notification Server Install Wizard will fail to detect a locally installed SQL Server 2005 when "localhost" is entered as the SQL Server name and the following error is returned: Failed to get the list of available databases, check your database credentials.

However, if you enter the computer name as the SQL Server name, the list of available databases for the local SQL 2005 Server will load without issue."


Applies To
Notification Server 6.0.6074 SP3
Microsoft SQL Server 2005
Microsoft SQL Server 2005 Express

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