KNOWN ISSUE: DAgent in WinPE 2.1 appears to hang at "Client Record Updated"
search cancel

KNOWN ISSUE: DAgent in WinPE 2.1 appears to hang at "Client Record Updated"

book

Article ID: 176722

calendar_today

Updated On:

Products

Deployment Solution

Issue/Introduction

When a client system boots into Windows PE 2.1, the DAgent starts and connects to the Deployment Server, but then appears to hang at "Client Record Updated".

This can occur when a Windows PE 1.6 boot configuration existed in a previous version of Deployment Solution before upgrading to Deployment Solution 6.9 ("WinPE Managed" is the default if automatically created during a Deployment Solution install), and this previously existing Windows PE 1.6 configuration is changed to a Windows PE 2.1 configuration, without checking the WMI option on step 7 of the Boot Disk Creater configuration.

Cause

When the Boot Disk Creator of Deployment Solution 6.9 converts a WinPE 1.6 configuration to WinPE 2.1, the WMI package on step 7 of the boot configuration wizard is not checked. When a new WinPE (either WinPE 1.6 or WinPE 2.1) configuration is created in the Boot Disk Creator, this option is automatically checked by default.

DAgent requires that WMI be enabled in WinPE for it to function properly. Because the WMI setting was lost in the conversion of a WinPE 1.6 configuration created in previous versions of Deployment Server, to WinPE 2.1, then WMI is not enabled in the WinPE 2.1 environment, causing DAgent to function incorrectly.

Resolution

This bug is fixed in Deployment Server 6.9 SP1


Applies To

Deployment Solution 6.9 upgraded from a previous version of Deployment Solution (6.8 SP2 or earlier) that had a Windows PE 1.6 configuration in either PXE or the Boot Disk Creator.

Windows PE 2.1 installed on Deployment Server 6.9, and Windows PE 1.6 from the previous install of Deployment Solution.