Agent is unable to download packages from new Package Server
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Agent is unable to download packages from new Package Server

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Article ID: 176719

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Updated On:

Products

IT Management Suite

Issue/Introduction

A new Package Server was introduced. It had downloaded all of the available packages from the Notification Server, but the agents on outlying computers are unable to download the packages from the Package Server. The agent dialog would show it checking each package and then revert to the status "Waiting to retry download."

The agent.log contained many instances of something similar to the following:

Error while downloading package: Server is busy.  Package sources request is backing off (-2147467259)

Server is busy. GetPackageInfo Server request will be retried in 120 minutes.

Cause

Ultimately, it is an IIS problem that existed before the base agent and Packager Server agent were installed. The Default Application Pool (DefaultAppPool) would not stay started, and, therefore, no virtual directories created (Altiris or other) could be accessed. Even new App Pools created would not stay started if access to a virtual directory assigned to them was attempted. In the event logs were trails of the following error:

Source: W3SVC
Type: Error
Event ID: 1002
Description: Application Pool 'DefaultAppPool' is being automatically disabled due to a series of failures in the process(es)serving that application pool ......

The problem is a rights issue where the network and or IUSR_Servername accounts were corrupted or not working correctly.

Resolution

Reinstall IIS to correct the problem. EventID 1002 has points to other options administrators have found in dealing with this problem.

Applies To

Notification Server 6.0.6074 SP3 R6