HTTP Request Failed: An unexpected network error occurred. (-2147024837)
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HTTP Request Failed: An unexpected network error occurred. (-2147024837)

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Article ID: 176694

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Updated On:

Products

IT Management Suite

Issue/Introduction

The following error messages are seen in the log:

<event date='Nov 07 06:32:47' severity='1' hostName='SERVER123' source='SecureSocket' module='AeXNetComms.dll' process='AeXNSAgent.exe' pid='1424' thread='4116' tickCount='282639484' >
  <![CDATA[Receive Error 183]]>
</event>
<event date='Nov 07 06:32:47' severity='1' hostName='SERVER123' source='HttpRequest' module='AeXNetComms.dll' process='AeXNSAgent.exe' pid='1424' thread='4116' tickCount='282639531' >
  <![CDATA[POST NTLM: Expected 401 during authentication]]>
</event>
<event date='Nov 07 06:32:47' severity='2' hostName='SERVER123' source='AeXNetworkTransport' module='AeXNetComms.dll' process='AeXNSAgent.exe' pid='1424' thread='4116' tickCount='282639546' >
  <![CDATA[GetFiles 'HTTPS://SERVER123.com/Altiris/Packages/%7B95894178-adb9-4f3c-8ee1-120cfafa8f36%7D/TestFile.data'->'C:\Program Files\Altiris\Altiris Agent\Software Delivery\{95894178-ADB9-4F3C-8EE1-120CFAFA8F36}\cache\TestFile.data' failed: HTTP Request Failed: An unexpected network error occurred. (-2147024837)]]>
</event>

The behavior being seen was that packages were not able to download, even when PAC (Package Access Credential) were given.  Trying to pass the same crdentials in IE also failed.

Cause

LAN Manager authentication levels were different on the Win2003 NS server and Win2000 clients.

Windows 2000 environments only using  "Send LM & NTLM responses" to a Windows 2003 NS Server configured to use "Send NTLMv2 responses Only \ Refuse LM"  This caused the authentication process to fail even after typing in access credentials when prompted in IE.


In another instance; found there were two scheduled tasks that were set to run at the same time. Found this was causing a conflict.

Resolution

Change the LAN Manager authentication levels to accept the same level between Win2000 and Win2003 systems.

Settings are found in Start > Administrative Tools > Local Security Policy > Security Settings > Local Policies > Security Options > Network Security: LAN Manager authentication level.



In another instance; found that setting the scheduled tasks to run separately had resolved the issue.

Applies To
NS 6.0.6074 R5 & R10

Server Win 2003

Clients Win 2000