Patches or Software Deliveries are Failing with Exit Code 1387
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Patches or Software Deliveries are Failing with Exit Code 1387

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Article ID: 176651

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Updated On:

Products

Patch Management Solution for Windows Software Management Solution

Issue/Introduction

There are a number of patch updates or software deliveries failing with status "Failed to start" and exit code 1387.

Cause

Net helpmsg 1387 indicates that this exit code means:

A member could not be added to or removed from the local group because the member does not exist.

Usually this is caused by a typo in the credentials that the task runs with.

To view what rights the task ran with open the Agent, go to the Software Delivery or Software Updates tab, open the package that failed, open the Run History tab, and look under the "Run with rights" column. This may show something like <domain>\<domain>\<user> for example if in the policy or task the domain was entered in the "User domain:" field and domain\name was entered in the "User name:" field.  

Resolution

Correct the Run As credentials in the Advanced options of the policy or task that failed.