Altiris Agent can't communicate through proxy
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Altiris Agent can't communicate through proxy

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Article ID: 176626

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Updated On:

Products

IT Management Suite

Issue/Introduction

The Altiris Agent fails to communicate through the configured Internet Explorer* proxy. The value of Proxy Server registry key has invalid content similar to the following:

[HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Communications]
"Proxy Server"="8080;https=proxy.fakecompany.com"
"Proxy Port"=dword:00001f90
"Proxy Auto Detect"=dword:00000001

Cause

The proxy auto detect function of the Altiris Agent is expecting the Microsoft registry keys to only contain a single Proxy server value. When separate proxy servers are specified per protocol, it confuses the text parsing function.

Resolution

This issue is resolved in Rollup 7 (R7) for Notification Server 6.0 SP3.  Release notes can be found in article 35803.

There are also two workarounds:

The first workaround is to configure Internet Explorer to use the same proxy server and port for all protocols as depicted below:

The second workaround is to manually correct the Proxy Server registry key, and set the Proxy Auto Detect value to 0 as listed below:

"Proxy Server"="proxy.fakecompany.com"
"Proxy Port"=dword:00001f90
"Proxy Auto Detect"=dword:00000000

Note:  The second workaround should only be used in environments where the Agent's host does not move between two different proxy environments.


Applies To
Notification Server 6.0 SP3 R5
Microsoft Windows XP* SP2 Altiris Agent host

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