Unable to browse .exe files from IIS
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Unable to browse .exe files from IIS

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Article ID: 176616

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Updated On:

Products

IT Management Suite

Issue/Introduction

In trying to push the Altiris Agent to computers the installation kept failing. When trying to browse out to the files in the NS Client Package folder in the IIS manager an error of "404 - Page not found" comes. Not the expected option to download or open the files in question. This was happening on two different computer systems unrelated to one another. After more testing, it was found that it was not possible to browse out to any executable (.exe) in the entire default Web site. The first site in question had other Web sites and, in other Web sites, it was possible to browse out to the executable files. The second site had just one Web site in IIS.

Cause

URLScan was blocking access to any .EXE. Looking under the 'Deny executables that could run on the server' section, .exe extension was listed as part of the DenyExtensions functionality.

Resolution

On the site with the URLScan, change the executable (.exe) to be enabled versus blocked and reset IIS. That resolves the issue for that system. Usually you can find the URLScan file that contains all these settings under this directory:
C:\WINDOWS\system32\inetsrv\urlscan

Changing the Home Directory settings (on the Notification Server) for the Default Web Site value of "Execute Permissions" to be "Scripts" resolved the issue. Using the "Scripts and Executables" value blocks the download of the .exe files.

You can find more details on URLScan and Notiifcation Server under Article ID: 2017 “How to use Notification Server with IIS lockdown and URLScan”


Applies To
Notification Server 6.0.6074 SP3 + Rx
IIS 6.0