VIP Access displays error 4010 or crashes after Android device upgrade
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VIP Access displays error 4010 or crashes after Android device upgrade

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Article ID: 176587

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Updated On:

Products

VIP Access for Mobile

Issue/Introduction

If an Android mobile device is upgraded to Android 9.0 Pie and the VIP Access app is launched before restarting the device, the security code may show all zeroes. A 4002/4010 error may also display.

VIP Access may crash (particularly on Samsung devices) after upgrading to Pie if the app was not first updated to the latest version (4.1.4 or later). This is due to security improvements that prevent applications from accessing TrustZone on the device where the credential ID was stored in versions prior to VIP Access 4.1.4.

Note: This issue does not occur if updating to the latest version of VIP Access for Android before upgrading to Android 9 (Pie).

"VIP Access cannot access files required to start. You must reactivate VIP Access and register it again as a new credential: 4010”

Or the app may crash with the following error message.

Cause

After an Android mobile device is upgraded to Android 9 Pie, VIP Access may not have access to critical files until the device is restarted, or the app has been updated.

 

Resolution

To fix this issue, update to the latest version of VIP Access. If the issue still persists, uninstall/reinstall VIP Access and register the new credential ID. 

 

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