The Event logs shows a DCOM error related to the service AeXNSClient
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The Event logs shows a DCOM error related to the service AeXNSClient

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Article ID: 176544

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Updated On:

Products

IT Management Suite

Issue/Introduction

Looking on the Event logs for a system, the following error message was found:

DCOM got error "The service cannot be started, either because it is disabled or because it is no enabled devices associated with it." attempting to start the service AeXNSClient with arguments "-Service" in order to run the server: {Machine GUID goes here}

Sometimes the Altiris Agent seems to be working fine or the Altiris Agent Installation failed after many attempts.

Cause

Unknown. Possibly multiple attempts of installing the Altiris Agent or faulty removal of the Altiris Agent.

Resolution

There are many alternatives to fix this issue.
  1. Check your Services. If you see multiple instances of the Altiris Agent Installation Service:
    • Altiris Agent Installation Service
    • Altiris Agent Installation Service0
    • Altiris Agent Installation Service01
    • Altiris Agent Installation Service012
    • Altiris Agent Installation Service0123
    • Altiris Agent Installation Service01234

      Try article 17553, "Multiple Instances of the Altiris Agent Installer Services listed in the Windows services list 'Altiris Agent Installation Service' "
  2. Check your RegKeys. Verify that the following RegKeys exist on the system: 
    • HKEY_LOCAL_MACHINE > SOFTWARE > Altiris > Altiris Agent 
    • HKEY_LOCAL_MACHINE > SOFTWARE > Altiris > eXpress
    • HKEY_LOCAL_MACHINE > SOFTWARE > Altiris > Scheduler 
    • HKEY_LOCAL_MACHINE > SOFTWARE > Altiris > APackageStub

      If they do and it is the first time installing the Altiris Agent or it was previously installed and then removed, try to follow the steps specified in articles 16924 and 1995 to completely remove the Altiris Agent.
  3. Install the Altiris Agent using any method desired. See article 30721, "How to perform a Push or Pull Installation of the Altiris Agent?"

    Note:
    If you use the AeXNSC.exe, and your base agent version is at least 6.0.2338, you will have to run the command aexagentutil.exe /server:yourservername to complete the installation. See article 28697, "Altiris Agent Utility Tool."
  4. If the agent service will still not start, find a working client and export the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AeXNSClient

    This key is "generic" and can be safely merged on to any client system.
  5. Copy the exported key to the troublesome system. Right-click and merge the key into the registry.

The Altiris Agent Service should now start or finish the Altiris Agent Installation.


Applies To
Notification Server 6.0.xxxx
Altiris Agent 6.0.xxxx

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